Main Forums >> Recording Techniques
        Print Thread

Pages: 1
Marbury
active member


Joined: 28/08/03
Posts: 1777
Loc: Cheshire, UK
Can't get Roland JP8080 working in midi chain
      #1060314 - 01/08/13 11:43 PM
I have a Yamaha Motif and a Roland JP8080 linked via a Edirol UM-2 2x in/out going into Reaper DAW.

I cannot for the life of me get the midi through to the Roland via the remote keynboard or midi in (It only has Remote In/Midi In/Midi Out) I had it working in Cubase SX3 but not in Reaper. Have checked all the settings in Reaper are correct. I have even tested the Motif midi out to the Roland's midi In is working fine. For Reaper I have Motif out to UM-2 In 1. Um-2 out 1 to Motif In. Motif Thru out to UM-2 in 2. Um-2 out 2 to Roland in. Even tried Motif's Thru direct to Roland, bypassing the UM-2 and still no joy.

--------------------
http://www.myspace.com/ianhubball


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Richie Royale



Joined: 12/09/06
Posts: 4403
Loc: Bristol, England.
Re: Can't get Roland JP8080 working in midi chain new [Re: Marbury]
      #1060360 - 02/08/13 09:47 AM
The JP 8080 has two MIDI ins, and an upper and lower split, which can add to the confusion of what is up.

First thing to do is click the preview button, so you can make sure sounds are coming out, using the preset selection keys to trigger it. Once you have established that, check the MIDI channel using the Edit, MIDI option. I think that the sounds are triggered from either input, but I could be wrong, one I know only triggers the Arp, so I would try either one. Otherwise there shouldn't be any other hidden aspect to triggering over MIDI.

--------------------
http://soundcloud.com/richie-royale
http://www.mixcrate.com/richieroyale


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
The Elf
active member


Joined: 14/08/01
Posts: 9567
Loc: Sheffield, UK
Re: Can't get Roland JP8080 working in midi chain new [Re: Richie Royale]
      #1060449 - 02/08/13 08:11 PM
Quote Richie Royale:

I think that the sounds are triggered from either input, but I could be wrong, one I know only triggers the Arp, so I would try either one.



True. The 'Remote' input lets an external MIDI keyboard simulate the JP-8080 having its own keyboard. The other MIDI input cannot make use of the arpeggiator. It's dumb, if you ask, me, but for some reason Roland decided this was the way to go.

--------------------
An Eagle for an Emperor, A Kestrel for a Knave.


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Marbury
active member


Joined: 28/08/03
Posts: 1777
Loc: Cheshire, UK
Re: Can't get Roland JP8080 working in midi chain new [Re: Richie Royale]
      #1060450 - 02/08/13 08:40 PM
Quote Richie Royale:

The JP 8080 has two MIDI ins, and an upper and lower split, which can add to the confusion of what is up.

First thing to do is click the preview button, so you can make sure sounds are coming out, using the preset selection keys to trigger it. Once you have established that, check the MIDI channel using the Edit, MIDI option. I think that the sounds are triggered from either input, but I could be wrong, one I know only triggers the Arp, so I would try either one. Otherwise there shouldn't be any other hidden aspect to triggering over MIDI.




Yes, one of the first things I did was preview the sound to test it was coming through. All midi settings in reaper correctly matching the Roland. Still can't get t going.

--------------------
http://www.myspace.com/ianhubball


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Marbury
active member


Joined: 28/08/03
Posts: 1777
Loc: Cheshire, UK
Re: Can't get Roland JP8080 working in midi chain new [Re: Marbury]
      #1063658 - 25/08/13 06:11 PM
I still can't get this synth to work via midi as it did in Cubase. I have the Motif's thru going direct to the Roland and have tried both midi and remote in with no joy. Again, have tested the audio out is working by pressing preview mode and it's working.

Please help !

--------------------
http://www.myspace.com/ianhubball


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
BJG145



Joined: 06/08/05
Posts: 3470
Loc: Norwich UK
Re: Can't get Roland JP8080 working in midi chain new [Re: Marbury]
      #1063662 - 25/08/13 06:34 PM
Quote Marbury:

I have a Yamaha Motif and a Roland JP8080 linked via a Edirol UM-2 2x... I have the Motif's thru going direct to the Roland




If you have two devices and a 2-in 2-out MIDI interface, why are you using MIDI thru? Much easier to keep everything on its own physical port when possible.


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
The Elf
active member


Joined: 14/08/01
Posts: 9567
Loc: Sheffield, UK
Re: Can't get Roland JP8080 working in midi chain new [Re: Marbury]
      #1063663 - 25/08/13 06:37 PM
Maybe you've already been here, but check the MIDI channels the JP-8080 is set for.

My memory fails me as to how it all hangs together, but there will likely be a 'global' MIDI channel for patch selection (and this also has something to do with the MIDI channel the connected keyboard assumes) and separate Upper/Lower Tone MIDI channels within each patch. It's easy to end up with these settings messed up, so double and triple check everything.

--------------------
An Eagle for an Emperor, A Kestrel for a Knave.


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Marbury
active member


Joined: 28/08/03
Posts: 1777
Loc: Cheshire, UK
Re: Can't get Roland JP8080 working in midi chain new [Re: Marbury]
      #1063664 - 25/08/13 06:39 PM
Ah, it's a Reaper problem. I have tried my Cubase SX3 and it works a dream only using the out 2 of my UM-2. I have set the correct midi in Reaper but I will try and delve deeper.

--------------------
http://www.myspace.com/ianhubball


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Marbury
active member


Joined: 28/08/03
Posts: 1777
Loc: Cheshire, UK
Re: Can't get Roland JP8080 working in midi chain new [Re: Marbury]
      #1063779 - 26/08/13 04:20 PM
Yes, I can now get control on SOME patches on the Roland but some do not respond. This is because it needs to be plugged into remote keyboard (Roland JP8080 has a weird midi setup). I switched back to remote keyboard in and it didn't work. For Reaper, I had to set the remote keyboard channel on the Roland from 4 (picked up ok in Cubase) to ALL and then it worked. Strangely, it only worked from the Reaper track in either midi channel 1 or All. The others didn't work, even tough set to ALL in the JP8080. Confused ?

--------------------
http://www.myspace.com/ianhubball


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
The Elf
active member


Joined: 14/08/01
Posts: 9567
Loc: Sheffield, UK
Re: Can't get Roland JP8080 working in midi chain new [Re: Marbury]
      #1063780 - 26/08/13 04:33 PM
The JP-8080 makes use of four MIDI channels.

One channel is the Remote Keyboard channel.
One channel is the Performance Control channel
One channel is the Upper Tone (Part) receiving channel
One channel is the Lower Tone (Part) receiving channel.

If the JP has been edited (and many people seem to get very confused about the channels and edit it to death in the hope of stumbling upon a solution), then your tones within each Performance may be set to their own channels, even though the JP may be responding to MIDI Program Change messages at the Performance level.

--------------------
An Eagle for an Emperor, A Kestrel for a Knave.


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
The Elf
active member


Joined: 14/08/01
Posts: 9567
Loc: Sheffield, UK
Re: Can't get Roland JP8080 working in midi chain new [Re: The Elf]
      #1063787 - 26/08/13 06:00 PM
(IIRC the first thing I did when I bought my JP-8080 was to set the Part MIDI channel to 'Off' in every Performance and re-save!)

--------------------
An Eagle for an Emperor, A Kestrel for a Knave.


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Pages: 1

Rate this thread

Jump to

Extra Information
1 registered and 78 anonymous users are browsing this forum.

Moderator:  David Etheridge, James Perrett, zenguitar, Martin Walker, Forum Admin, Hugh Robjohns, Zukan, Frank Eleveld, SOS News Editor,  
Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled
Rating:
Thread views: 3458

November 2014
On sale now at main newsagents and bookstores (or buy direct from the
SOS Web Shop)
SOS current Print Magazine: click here for FULL Contents list
Click image for November 2014
DAW Tips from SOS

 

Home | Search | News | Current Issue | Tablet Mag | Articles | Forum | Subscribe | Shop | Readers Ads

Advertise | Information | Privacy Policy | Support | Login Help

 

Email: Contact SOS

Telephone: +44 (0)1954 789888

Fax: +44 (0)1954 789895

Registered Office: Media House, Trafalgar Way, Bar Hill, Cambridge, CB23 8SQ, United Kingdom.

Sound On Sound Ltd is registered in England and Wales.

Company number: 3015516 VAT number: GB 638 5307 26

         

All contents copyright © SOS Publications Group and/or its licensors, 1985-2014. All rights reserved.
The contents of this article are subject to worldwide copyright protection and reproduction in whole or part, whether mechanical or electronic, is expressly forbidden without the prior written consent of the Publishers. Great care has been taken to ensure accuracy in the preparation of this article but neither Sound On Sound Limited nor the publishers can be held responsible for its contents. The views expressed are those of the contributors and not necessarily those of the publishers.

Web site designed & maintained by PB Associates | SOS | Relative Media