Main Forums >> PC Music
        Print Thread

Pages: 1
Shonn Frank



Joined: 08/01/13
Posts: 16
PCI Latency on Windows 7
      #1028231 - 12/01/13 02:36 AM
Hello sos,


First of all thank you for the wealth of information. Whenever I am online researching something specific or just trying to learn something new, I always seem to end up here reading a great article.
And today I thought I FINALLY found a solution to my problems, three audio interfaces later. I am absolutely convinced that I suffer from high latency values for my video and graphics cards on my PCI Bus.......as it was explained in an archived article. That's why I get those %#&* clicks and pops even though my CPU is at 30% and less than half my RAM is used AND probably why it happens mostly when I move a window or edit a waveform...etc.

So, this is a happy day BUT the tool mentioned, Double Dawg and the PCI Latency Tool are incompatible with Windows 7 64(sp1) and I am not finding ANYTHING anywhere about other possible tools or anyway at all to address this issue. lol

It seemed to have helped many people with windows xp, then a few inquired like I am....but no resolution. It makes me think it must be something very simple, right? (wishful thinking)

Can anyone help with this. It will end years of suffering. thx

--------------------
Thank You


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Nevertra



Joined: 12/01/13
Posts: 2
Loc: NSW,Australia
Re: PCI Latency on Windows 7 new [Re: Shonn Frank]
      #1028237 - 12/01/13 09:05 AM
Currently running a Sound Blaster Recon3D FATAL1TY Champion series PCI sound card on Windows 7 64 bit. Latency is really bad.
Any help would be appreciated.
DAW is Samplitude Producer 11.5 8gB ram Intel I5


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Pete Kaine
Scan Computers


Joined: 10/07/03
Posts: 3681
Loc: Manchester
Re: PCI Latency on Windows 7 new [Re: Shonn Frank]
      #1028487 - 14/01/13 09:35 AM
Shonn : Which latency tool did you try?

http://www.thesycon.de/deu/latency_check.shtml run that and let us know what your seeing.
What sound interfaces have you been trying? What is the system spec?

Nevertra : Your using a creative card who's drivers tend to be dog rough in recording terms at a best of times... except a quick Google mentions that they don't support ASIO 2.0 these days :-/

So I'm guessing your using ASIO4ALL at this point? If not then you should be, althrough I'd argue that its nothing better than a stop gap solution and you should be looking at a proper recording interface.

--------------------
ScanProAudio & 3XS Audio Systems
ScanProAudio Blog


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Magic Matt



Joined: 17/09/10
Posts: 141
Re: PCI Latency on Windows 7 new [Re: Shonn Frank]
      #1028540 - 14/01/13 02:09 PM
Sound Blaster cards are for gaming, not music production. If I were building a gaming rig, then a Sound Blaster card is a wonderful addition, but for recording they are a nightmare - they just don't have the right kind of driver support needed to perform well in recording scenarios.

Your best bet would be to use a different recording interface that has drivers designed for use in music production. The extra expense is inconvenient, but well worth it for the added usability and stability you should get.


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Shonn Frank



Joined: 08/01/13
Posts: 16
Re: PCI Latency on Windows 7 new [Re: Pete Kaine]
      #1028648 - 15/01/13 04:33 AM
Hey Pete,

thx

OK specs 4ghz Intel Pentium 4Gb Ram. It is a Toshiba laptop, not at all geared toward audio, more video with an Intel HD graphics card (I set the performance a low as I could. 16 Bit), webcam and skype. Still, I'm only running like 6 tracks of actual audio + a VST sampler (Geist) and an average amount of effects.

I've spent the last 48 hours doing every tweak that has ever been mentioned I think. I had many done, but now I have a separate user profile, anything that isnt audio is uninstalled or disabled, no internet, most non-vital services shut down, fully defragged....etc.

The tweaks did improve it some what, as well it should I am running bare bones, but still spikes and dropouts.

As far as latency, I tried Double Dawg and PCI Latency Tool, neither will run on windows 7 (64bit sp1). I also tried Power Strip, which is for the video card actually, and it does have a spot to change the IRC and latency values but they are greyed out.

I just now ran the DPC latency checker and it came out ok. It said the machine should handle audio fine. Absolute value was 200u. It averaged about 70-90u.

So, is that it for the Graphics card/Display adapter/PCI latency/IRQ value theory? A red herring?
lol

thx for the help


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Shonn Frank



Joined: 08/01/13
Posts: 16
Re: PCI Latency on Windows 7 new [Re: Pete Kaine]
      #1028651 - 15/01/13 04:41 AM
Quote Pete Kaine:


What sound interfaces have you been trying? What is the system spec?






Yeah, I have had poor performance with 3 interfaces, EMU 0404 USB, MBox 1 & 2. Currently using the creative EMU.

Perhaps Nevertra would be interested in one of the other two.. lol @Never You could find a servicable one for pretty cheap.

--------------------
Thank You


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Skerrick



Joined: 10/01/13
Posts: 262
Loc: Sydney NSW
Re: PCI Latency on Windows 7 new [Re: Shonn Frank]
      #1028652 - 15/01/13 05:16 AM
Quote Shonn Frank:

Hey Pete,

thx

OK specs 4ghz Intel Pentium 4Gb Ram. It is a Toshiba laptop, not at all geared toward audio, more video with an Intel HD graphics card (I set the performance a low as I could. 16 Bit), webcam and skype. Still, I'm only running like 6 tracks of actual audio + a VST sampler (Geist) and an average amount of effects.

I've spent the last 48 hours doing every tweak that has ever been mentioned I think. I had many done, but now I have a separate user profile, anything that isnt audio is uninstalled or disabled, no internet, most non-vital services shut down, fully defragged....etc.

The tweaks did improve it some what, as well it should I am running bare bones, but still spikes and dropouts.

As far as latency, I tried Double Dawg and PCI Latency Tool, neither will run on windows 7 (64bit sp1). I also tried Power Strip, which is for the video card actually, and it does have a spot to change the IRC and latency values but they are greyed out.

I just now ran the DPC latency checker and it came out ok. It said the machine should handle audio fine. Absolute value was 200u. It averaged about 70-90u.

So, is that it for the Graphics card/Display adapter/PCI latency/IRQ value theory? A red herring?
lol

thx for the help




man onboard soundcards are shite, the good ones are so expensive you might as well buy a usb soundcard. get a focusrite scarlett 2i2, itll solve ALL your problems with crackling and latency, its about $120 and its one of the best available at entry level, especially for that price.
i had my buffer at about 50ms to 70ms without the focusrite soundcard and now my latency is at 3ms and it works like a charm. theres no clipping on heavily layered (30 or more channels) tracks and its so easy to record live instruments and vocals, its really an essential item.
another problem might be the intel integrated graphics, if youre running your DAW on that system, you want the DAW to be the only thing open on your pc, whereas with dedicated graphics, the graphics card diverts its processing power to whatever you have open in front of you rather than carrying the whole system on its back at all times. i hope that made sense, i guarantee as soon as you add an audio interface into the mix (pardon the pun) youll notice/hear a world of difference.
good luck man, honestly. invest in the "focusrite scarlett 2i2" - you wont be disappointed.
hope i was of some help..
the clicks and pops are cpu noise making their way into your mix, the soundcard has a separate processor dedicated to rendering and taking the load of the sounds off the cpu and taking care of them separately.
peace.

--------------------
www.soundcloud.com/skerrick


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Skerrick



Joined: 10/01/13
Posts: 262
Loc: Sydney NSW
Re: PCI Latency on Windows 7 new [Re: Shonn Frank]
      #1028653 - 15/01/13 05:18 AM
funnily enough i read a post elsewhere where a guy had the emu 0404 and was having epic troubles with clipping.
i also suggested he get a focusrite scarlett.

--------------------
www.soundcloud.com/skerrick


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Pete Kaine
Scan Computers


Joined: 10/07/03
Posts: 3681
Loc: Manchester
Re: PCI Latency on Windows 7 new [Re: Shonn Frank]
      #1028685 - 15/01/13 10:42 AM
Quote Shonn Frank:


OK specs 4ghz Intel Pentium 4Gb Ram. It is a Toshiba laptop, not at all geared toward audio, more video with an Intel HD graphics card (I set the performance a low as I could. 16 Bit), webcam and skype. Still, I'm only running like 6 tracks of actual audio + a VST sampler (Geist) and an average amount of effects.





Yeah, your DPC looks fine.


You may find it behaves better with the gfx performance raised up again. I can't imagine many modern vsti gui's responding well to being run in 16bit mode!

You say it's a 4ghz Pentium, without a model number or something that could be from any Intel range in the last decade or so. That and I don't recall any 4ghz mobile chips making it to market! Could you post up the model of the laptop or run Speccy Free ( http://www.piriform.com/speccy/download ) and post up what info it returns in the CPU section to help us work out what generation it is from.

You've not mentioned what is happening with your CPU load when it clicks. What does the asio meter in your sequencer show and what does the CPU load meter in windows task manager show?

--------------------
ScanProAudio & 3XS Audio Systems
ScanProAudio Blog


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Shonn Frank



Joined: 08/01/13
Posts: 16
Re: PCI Latency on Windows 7 new [Re: Skerrick]
      #1028803 - 15/01/13 08:58 PM
Quote Skerrick:

funnily enough i read a post elsewhere where a guy had the emu 0404 and was having epic troubles with clipping.
i also suggested he get a focusrite scarlett.





Sorry bro, I posted it below. I have 3 audio interfaces: 2 MBox's and a creative EMU, which I'm using. And being a collector of cheap-as-possible interfaces, I have wondered about the Focusrite...they have nice little hardware pre-amps.

Thanks for the reply, though. Good advice. I would be asking you about the graphics card, specifically about if/how ditch the Intel HD and downgrade to something more modest. There's no doubt that this thing LOVES video.

BUT I'm gonna get on with my business of making music, since I lost 2 1/2 days to this crap. Because I am happy to report, yet pissed off that it took me this long to get to something so obvious. (Nice learning experience I suppose. lol) A couple weeks ago I was on a forum reading a discussion on the "wealth" of free plugins that are out....gave links to all these "great" plug-ins he had found. So, like an idiot.... It was a bad plugin.

Gotta be careful with "indie" plug-ins.

Thanks SOS friends.

--------------------
Thank You


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Shonn Frank



Joined: 08/01/13
Posts: 16
Re: PCI Latency on Windows 7 new [Re: Pete Kaine]
      #1028806 - 15/01/13 09:15 PM
Quote Pete Kaine:



Yeah, your DPC looks fine.


You may find it behaves better with the gfx performance raised up again. I can't imagine many modern vsti gui's responding well to being run in 16bit mode!

You say it's a 4ghz Pentium, without a model number or something that could be from any Intel range in the last decade or so. That and I don't recall any 4ghz mobile chips making it to market! Could you post up the model of the laptop or run Speccy Free ( http://www.piriform.com/speccy/download ) and post up what info it returns in the CPU section to help us work out what generation it is from.

You've not mentioned what is happening with your CPU load when it clicks. What does the asio meter in your sequencer show and what does the CPU load meter in windows task manager show?





So, as you probably see, I have found the problem--- a third party, freebie, stupid effect plug-in that I would've never used. lol

Thanks

For the record, I shouldve said Intel Pent B940 and you're right, from my understanding they screwed the music community and started making everything multi-core...so I should've said dual core 2ghz/2ghz.

Also, I probably wasnt clear, but the spikes were hitting around 50% in, maybe, 10 second intervals.....as shown by the task manager.

And good point about the 32bit grx; I hadn't thought of that. Actually never made the GUI connection until this little mess. I'm gonna try to bump it back to 32 bit. Take it easy. I'll be back with something

soon I'm sure. You guys are very helpful.

--------------------
Thank You


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
ef37a



Joined: 29/05/06
Posts: 7039
Loc: northampton uk
Re: PCI Latency on Windows 7 new [Re: Shonn Frank]
      #1028830 - 16/01/13 12:02 AM
I notice the Emu 0404 usb was mentioned?

Pre W7 this was the top recc' small interface and I toyed with the idea of getting one but was a bit strapped back then.

Come W7 and the box seemed to fall out of favour and there were whisperings of driver problems (well tbh I think Blista killed it off Emu did not bother a lot for W7?)

Can anyone confirm that the 0404 is really only XP happy? I ask because I keep a weather eye on my local Cash Converter. Picked up a Tascam 122L a few weeks ago £40. Seems fine on W7 but mic amps are V low gain and the 0404 was said to be very good in this regard?

Dave.


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Goddard



Joined: 04/04/12
Posts: 960
Re: PCI Latency on Windows 7 new [Re: ef37a]
      #1028840 - 16/01/13 01:53 AM
Quote ef37a:

I notice the Emu 0404 usb was mentioned?

Pre W7 this was the top recc' small interface and I toyed with the idea of getting one but was a bit strapped back then.

Come W7 and the box seemed to fall out of favour and there were whisperings of driver problems (well tbh I think Blista killed it off Emu did not bother a lot for W7?)

Can anyone confirm that the 0404 is really only XP happy? I ask because I keep a weather eye on my local Cash Converter. Picked up a Tascam 122L a few weeks ago £40. Seems fine on W7 but mic amps are V low gain and the 0404 was said to be very good in this regard?

Dave.




Afaik, no Win7 support for 0404 USB. Only for the 0404 PCIe card version, and latest drivers (Aug '12) for that were Beta and unsupported.

Btw, afaik that Tascam 122L uses Ploytec's USB ASIO drivers:

http://www.usb-audio.com/


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Pete Kaine
Scan Computers


Joined: 10/07/03
Posts: 3681
Loc: Manchester
Re: PCI Latency on Windows 7 new [Re: Shonn Frank]
      #1028854 - 16/01/13 09:48 AM
Quote Shonn Frank:


For the record, I shouldve said Intel Pent B940 and you're right, from my understanding they screwed the music community and started making everything multi-core...so I should've said dual core 2ghz/2ghz.





Hey, multicore is fine now all the software is optimized for it. Good news on finding the fault through

--------------------
ScanProAudio & 3XS Audio Systems
ScanProAudio Blog


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Nevertra



Joined: 12/01/13
Posts: 2
Loc: NSW,Australia
Re: PCI Latency on Windows 7 new [Re: Magic Matt]
      #1029047 - 17/01/13 11:26 AM
Thanks for info Matt


Post Extras: Print Post   Remind Me!   Notify Moderator     Back to top
Pages: 1

Rate this thread

Jump to

Extra Information
0 registered and 13 anonymous users are browsing this forum.

Moderator:  David Etheridge, James Perrett, zenguitar, Martin Walker, Forum Admin, Hugh Robjohns, Zukan, Frank Eleveld, SOS News Editor,  
Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled
Rating:
Thread views: 6730

January 2015
On sale now at main newsagents and bookstores (or buy direct from the
SOS Web Shop)
SOS current Print Magazine: click here for FULL Contents list
Click image for January 2015
DAW Tips from SOS

 

Home | Search | News | Current Issue | Tablet Mag | Articles | Forum | Blog | Subscribe | Shop | Readers Ads

Advertise | Information | Privacy Policy | Support | Login Help

 

Email: Contact SOS

Telephone: +44 (0)1954 789888

Fax: +44 (0)1954 789895

Registered Office: Media House, Trafalgar Way, Bar Hill, Cambridge, CB23 8SQ, United Kingdom.

Sound On Sound Ltd is registered in England and Wales.

Company number: 3015516 VAT number: GB 638 5307 26

         

All contents copyright © SOS Publications Group and/or its licensors, 1985-2014. All rights reserved.
The contents of this article are subject to worldwide copyright protection and reproduction in whole or part, whether mechanical or electronic, is expressly forbidden without the prior written consent of the Publishers. Great care has been taken to ensure accuracy in the preparation of this article but neither Sound On Sound Limited nor the publishers can be held responsible for its contents. The views expressed are those of the contributors and not necessarily those of the publishers.

Web site designed & maintained by PB Associates | SOS | Relative Media