You are here

Logic Pro Automation Trim Bug???

For current or would-be users of Apple Mac computers, with answers to many FAQs.

Logic Pro Automation Trim Bug???

Postby LimitedHeadroom » Tue Jun 17, 2014 10:33 am

When I try to trim automation by dragging up or down on the number value in the track header Logic tries to move the track up or down instead, then when I release the mouse, the track flickers rapidly for a couple of seconds and is still attached to the mouse pointer, so if I move the pointer up or down after I've let the track go I will put the track into a new location.

The only way to trim automation now is to select all the nodes in a track by dragging over them, and then drag a node up or down.

This happens on both my laptop and desktop so I'd be surprised if I'm the only one. Is anyone else getting this behaviour?
LimitedHeadroom
Poster
Posts: 45
Joined: Sat Sep 06, 2003 11:00 pm

Re: Logic Pro Automation Trim Bug???

Postby desmond » Tue Jun 17, 2014 12:10 pm

Which version of Logic are you referring to?
User avatar
desmond
Jedi Poster
Posts: 6499
Joined: Tue Jan 10, 2006 12:00 am

mu:zines | music magazine archive | Latest: MT Dec 90
Needed: SOS April 1993. Can you donate your copy to complete the early SOS archive?


Re: Logic Pro Automation Trim Bug???

Postby desmond » Tue Jun 17, 2014 1:00 pm

I get the same behaviour that you describe in LPX 10.0.7 (the most recent version).

I'd file it as a bug...
User avatar
desmond
Jedi Poster
Posts: 6499
Joined: Tue Jan 10, 2006 12:00 am

mu:zines | music magazine archive | Latest: MT Dec 90
Needed: SOS April 1993. Can you donate your copy to complete the early SOS archive?


Re: Logic Pro Automation Trim Bug???

Postby stratquebec » Tue Jun 17, 2014 1:14 pm

Some LPX code chuncks should be rewritten in swift
User avatar
stratquebec
Regular
Posts: 243
Joined: Sat Oct 29, 2005 11:00 pm
Location: Quebec/Canada

Re: Logic Pro Automation Trim Bug???

Postby desmond » Tue Jun 17, 2014 1:24 pm

There are quite a few UI issues in LPX as the revamp of the UI is not yet (I suspect) finished and it was a big task - some areas still look unfinished (ie some of the plugins are still the old, small, non-retina guis but others have been overhauled, the plugin header is perhaps the ugliest collection of Cocoa objects ever put in a window by Apple, and other such things...)
User avatar
desmond
Jedi Poster
Posts: 6499
Joined: Tue Jan 10, 2006 12:00 am

mu:zines | music magazine archive | Latest: MT Dec 90
Needed: SOS April 1993. Can you donate your copy to complete the early SOS archive?


Re: Logic Pro Automation Trim Bug???

Postby LimitedHeadroom » Tue Jun 17, 2014 11:25 pm

Yeah, I'm using LPX 10.0.7. How do you go about filing a bug report? Google will be my friend here. At least automation trim still works just fine in LP9. I'm not fully converted yet, but have been starting new projects in LPX recently. I think a lot of the workflow is better, but this is a pretty big niggle.

Lets hope they get the interface sorted before to long.
LimitedHeadroom
Poster
Posts: 45
Joined: Sat Sep 06, 2003 11:00 pm

Re: Logic Pro Automation Trim Bug???

Postby desmond » Wed Jun 18, 2014 1:31 am

LimitedHeadroom wrote:Yeah, I'm using LPX 10.0.7. How do you go about filing a bug report? Google will be my friend here. At least automation trim still works just fine in LP9. I'm not fully converted yet, but have been starting new projects in LPX recently. I think a lot of the workflow is better, but this is a pretty big niggle.

Preferable - if you have a developer account, the you can file a radar:
http://bugreport.apple.com

Otherwise, use the LP feedback page:
http://www.apple.com/feedback/logic-pro.html
User avatar
desmond
Jedi Poster
Posts: 6499
Joined: Tue Jan 10, 2006 12:00 am

mu:zines | music magazine archive | Latest: MT Dec 90
Needed: SOS April 1993. Can you donate your copy to complete the early SOS archive?


Re: Logic Pro Automation Trim Bug???

Postby LimitedHeadroom » Tue Jun 24, 2014 9:36 am

Thanks, bug report filed.
LimitedHeadroom
Poster
Posts: 45
Joined: Sat Sep 06, 2003 11:00 pm


Who is online

Users browsing this forum: No registered users and 2 guests