You are here

Q. What's wrong with my patchbay?

Published June 2005
By Hugh Robjohns

Neutrik 48 Jack patch bay.

I have a Neutrik quarter-inch jack patchbay that I'm having problems with. The unit is only a few months old but already I seem to be suffering from poor connections, with signals being quiet or not coming through properly and becoming distorted. I have isolated my outboard and tried different cables to check if the problem lies with these, and all roads lead back to the patchbay. Are there any methods for cleaning the contacts in patchbays or fixing them? The patchbays I had before never had any of these problems and I was using them for over four years.

SOS Forum Post

Technical Editor Hugh Robjohns replies: It is very unusual for a patchbay to become unreliable in such a short time. I presume there is no obvious environmental problem such as excessive dust, damp or smoke? Dust, damp and smoke tend to work together, gathering on the socket contacts to form a sticky residue which acts as a high-resistance layer, giving the kind of problems you seem to be experiencing. It helps if you can make sure the faceplate of the patchbay is vertical in the rack, rather than horizontal or sloping, as this minimises the risk of dust falling into the sockets, and that the room is kept dehumidified and well ventilated.

Another related cause is dirty (tarnished) plugs. This used to be a real problem in professional studios using PO316 or bantam patch cords which employed brass plugs, but tends not to be an issue with the plated domestic quarter-inch plugs used in most home-studio rigs. Professional studios using brass patch plugs often use a mechanical burnisher to clean and polish the plugs, along with an aggressive cleaner for the sockets, but the equipment is designed to be cleaned in this way. The plated domestic plugs and sockets are often quite soft in comparison and will wear out very quickly if treated this way, so gentle hand cleaning with a mild metal polish or contact cleaner — Deoxit or Servisol, for example — might help. Don't get too enthusiastic though: excessive rubbing with an abrasive cleaner will quickly damage or even remove the plating, making your problems a whole lot worse! A quick wipe over with one of the gentle cleaners mentioned above every month or two should keep everything in good order, if surface contamination is the problem.

Another likely problem, probably the most likely, in fact, is that your patch cables are of a non-standard size. Some of the cheaper Chinese-made moulded patch cables are fitted with locally made plugs that are slightly undersized and don't conform to the correct quarter-inch specifications. Consequently, they sometimes don't make reliable contact with some types of socket. The solution here is obvious: try patching using good-quality leads (ideally with Neutrik jacks on the end), and see if that works any more reliably.

Published June 2005

Issue navigator