You are here

Behringer C-2 malfunction

Page 1 of 1

Behringer C-2 malfunction

PostPosted: Sun Dec 15, 2019 8:21 pm
by Horeli
Hello!

I recently bought a pair of Behringer C-2 sdc mics to record percussion instruments, but one of them seems to have an issue. When it's plugged to my sound card, it constantly generates low-pitched static noise which renders it completely unusable, while the second one works perfectly fine.
Image

I use cheap t-bone xlr cables from thomann, so my first guess was that one of the cables was damaged, and I replaced it with a new one: same result.
My father then gave me one of his own cables, which he was probably already using back in the 90's and feels pretty sturdy. It seems to have solved the problem to an extent, since the static noise has disappear during recording, but I still get a pop/cracking sound (not sure how it's called) when I (un)plug the cable in the sound card (phantom power is turned off).

So, to summarize, I have 2 microphones and 4 cables. Mic 1 works fine with each cable, but mic 2 only works with one specific cable. Why is that?
My sound card is a UR22mkII.

Sorry in advance if the answer to that question is obvious to you, I'm a total newbie when it comes to recording!

Fixed image link following Wonks' post - JP

Re: Behringer C-2 malfunction

PostPosted: Sun Dec 15, 2019 8:46 pm
by Hugh Robjohns
This kind of seemingly illogical problem is often due to Chinese XLR connectors which don't quite comply with the dimensions of the Cannon spec, and so don't fit accurately. As a result, the plug moves in the socket and so you get unwanted noise, crackles, splats and so on.

We had a similar problem in a recent Studio SOS where an sE4400 mic produced random crackles and splats. Turned out the cheap XLR cables were the problem... Switched to cables with genuine Neutrik connectors and there were no more problems.

Sometimes, of course, the problem is the XLR socket in the mic or other device, rather than the cable... So some experimentation may be required to find a combination of XLR types that work reliably.

Re: Behringer C-2 malfunction

PostPosted: Sun Dec 15, 2019 9:06 pm
by Horeli
Thanks a lot for your answer!

I'll follow your advice and buy proper xlr cables which will hopefully solve that problem. If it's a mic socket problem -which is very likely according to what you said-, I'll make good use of the warranty.

Re: Behringer C-2 malfunction

PostPosted: Sun Dec 15, 2019 10:48 pm
by Wonks
FYI, your image failed to display because you were linking to the web page itself and not the image. If the link doesn't end with .jpg or .png (or other common photo file type extensions), then you won't get a picture.

Image

Re: Behringer C-2 malfunction

PostPosted: Wed Dec 18, 2019 11:27 am
by Tim Gillett
You didn't say whether the mic is new or used. It's worth checking the actual XLR pins for tarnishing/corrosion. They should be clean, looking presumably like the pins on the good mic.