You are here

UAD Apollo Incompatibility with OS X Catalina?

All about the tools and techniques involved in capturing sound, in the studio or on location.

UAD Apollo Incompatibility with OS X Catalina?

Postby BassFacer67 » Wed Apr 01, 2020 1:34 am

I have decided I want to buy an Apollo Twin X Duo. I am buying a mac mini for the purpose of running Logic Pro X.

I have read that UAD is having compatibility issues with Catalina and recommends running on Mojave. The new macs and even refurbished ones from recent years all have Catalina

Is this still an issue? Are any Catalina users with Apollos experiencing problems?

Thanks,
Z
BassFacer67
Poster
Posts: 24
Joined: Thu Dec 18, 2014 1:00 am

Re: UAD Apollo Incompatibility with OS X Catalina?

Postby ore_terra » Wed Apr 01, 2020 8:24 am

my apollo twin duo works fine with the MBP I have with Catalina.
User avatar
ore_terra
Frequent Poster
Posts: 674
Joined: Fri Dec 02, 2016 1:56 pm
Location: Seville - Spain

Re: UAD Apollo Incompatibility with OS X Catalina?

Postby ore_terra » Wed Apr 01, 2020 8:24 am

ooops. apologies I missed the "X". mine is the thunderbolt 2 version
User avatar
ore_terra
Frequent Poster
Posts: 674
Joined: Fri Dec 02, 2016 1:56 pm
Location: Seville - Spain

Re: UAD Apollo Incompatibility with OS X Catalina?

Postby Wonks » Wed Apr 01, 2020 8:55 am

The official UAD stance is that it's still not fully tested and whilst the latest UAD drivers will now run on it, there is no guarantee that you won't run into any problems or crashes.

This last update was supposedly issued yesterday.

https://help.uaudio.com/hc/en-us/articl ... ility-Info
User avatar
Wonks
Jedi Poster
Posts: 10882
Joined: Thu May 29, 2003 12:00 am
Location: Reading, UK
Correcting mistakes on the internet since 1853