You are here

Rodecaster Pro logic question

All about the tools and techniques involved in capturing sound, in the studio or on location.

Moderator: Moderators

Rodecaster Pro logic question

Postby blinddrew » Thu Apr 16, 2020 4:47 pm

Today has been a complete ball-ache and I confess that brain is a little bit mush. So I'm hoping that someone(s) can just help me out with a simple confirmation that I'm not missing anything here.
I hosted a podcast today and, current environment in point, everyone was dialled in.
- I was hosting using a microphone into channel one.
- A second participant was dialed in via Zoom and the USB connection.
- A third was dialled in via the bluetooth channel,
- And a fourth via the 3.5mm TRRS jack.

All should have been ok, but:
- I could hear and speak to everyone,
- the people on the USB channel and the bluetooth channel could hear me, and each other, and the person on the 3.5mm jack channel.
- But the person on the 3.5mm channel could hear and speak to me, but couldn't hear the people on the USB or bluetooth channel.

So to my thinking:
- it can't be a cable or phone problem on the 3.5mm channel, because otherwise they wouldn't be able to hear and speak to me.
- it can't be a problem with anything connected to the USB or bluetooth channels as they all worked completely fine.
- it can't be a problem with my mic as everyone could hear that.

So the problem must be in the Rodecaster somewhere? Audio from USB and Bluetooth channels not being routed to the 3.5mm channel.

Does that stack up logically or have I missed something?
Thanks!
User avatar
blinddrew
Jedi Poster
Posts: 14202
Joined: Sun Jul 05, 2015 12:00 am
Location: York
Ignore the post count, I have no idea what I'm doing...

Re: Rodecaster Pro logic question

Postby Hugh Robjohns » Thu Apr 16, 2020 5:31 pm

Sounds like a problem with the mix-minus (cleanfeed) arrangements. You would expect every output to be able to hear every other source but not themselves... which appears to be true for most but not all.... Odd.

Have you checked the firmware is up to date? 2.04 is the current official version, and there's a beta of 2.1 with extra features. I couldn't find a bug list...

If there isn't a setup menu to configure the mix-minus arrangements, and if you're sure the phone connector was of the correct type and inserted correctly, then I'd contact Rode directly and ask them. They are usually very helpful with their support... although I don't know what the current situation is with Covid in Sydney.
User avatar
Hugh Robjohns
Moderator
Posts: 30660
Joined: Fri Jul 25, 2003 12:00 am
Location: Worcestershire, UK
Technical Editor, Sound On Sound
In my world, things get less strange when I read the manual... 

Re: Rodecaster Pro logic question

Postby blinddrew » Thu Apr 16, 2020 5:39 pm

Hugh Robjohns wrote:Sounds like a problem with the mix-minus (cleanfeed) arrangements. You would expect every output to be able to hear every other source but not themselves... which is true for most but not all.

If there isn't a setup menu to configure the mix-minus arrangements, and if you're sure the phone connector was of the correct type and inserted correctly, then I'd contact Rode directly and ask them. They are usually very helpful with their support... although I don't know what the current situation is with Covid in Sydney.
There is a mix-minus setting in the channel configurations but it was set the same for all three channels. I've raised a ticket with Rode, I just wanted a bit of a check that I wasn't being a complete muppet (more so than usual that is).

EDIT - my bad, the mix-minus setting is only for the USB channel. So that shouldn't be effecting the 3.5mm jack channel.
I shall wait and see what Rode say.
Thanks
User avatar
blinddrew
Jedi Poster
Posts: 14202
Joined: Sun Jul 05, 2015 12:00 am
Location: York
Ignore the post count, I have no idea what I'm doing...

Re: Rodecaster Pro logic question

Postby blinddrew » Thu Apr 23, 2020 7:04 pm

Just a quick update, swapping the phones around has fixed it. I'm not sure why or how that should be the case, but it's working so... :headbang:
User avatar
blinddrew
Jedi Poster
Posts: 14202
Joined: Sun Jul 05, 2015 12:00 am
Location: York
Ignore the post count, I have no idea what I'm doing...

Re: Rodecaster Pro logic question

Postby Sebcrateisdiggin » Sun Dec 27, 2020 6:51 pm

Hello,
I meet a problem with the micro sd on my Macbook Pro.
When I transfer the sd card recording via Rodecaster Pro to my Macbook Pro, I see, by double clicking on the Wav. that the song does not appear on Itunes. Can you tell me how I should do this, please.
Thank you very much for your attention and your time.
Sebastien
Sebcrateisdiggin
Posts: 1
Joined: Sun Dec 27, 2020 6:48 pm

Re: Rodecaster Pro logic question

Postby Sam Spoons » Sun Dec 27, 2020 9:55 pm

If your MBP can see the card then try using 'add to library' in the iTunes File menu.
User avatar
Sam Spoons
Jedi Poster
Posts: 15622
Joined: Thu Jan 23, 2003 1:00 am
Location: Manchester UK
Still taking this recording lark seriously (and trying to record my Gypsy Jazz CD)........

Re: Rodecaster Pro logic question

Postby Kwackman » Sun Dec 27, 2020 10:54 pm

I'm not sure if this would explain it, but you weren't in "Producer Mode" on that phone were you?
User avatar
Kwackman
Frequent Poster (Level2)
Posts: 2191
Joined: Thu Nov 07, 2002 1:00 am
Location: Belfast
Cubase, guitars.

Re: Rodecaster Pro logic question

Postby blinddrew » Mon Dec 28, 2020 12:49 am

If you're just dragging the polywav file across then i wouldn't expect itunes to be able to read it.
User avatar
blinddrew
Jedi Poster
Posts: 14202
Joined: Sun Jul 05, 2015 12:00 am
Location: York
Ignore the post count, I have no idea what I'm doing...