You are here

Korg Wavestation instability in Logic Pro X?

For current or would-be users of Apple Mac computers, with answers to many FAQs.

Moderator: Moderators

Re: Korg Wavestation instability in Logic Pro X?

Postby Dave B » Thu Aug 23, 2018 5:24 pm

I get an occasional crash with 10.4.1 and the Wavey. Mainly on re-opening projects iirc. But it's by no means every time. It's infrequent enough to be a niggle rather than a problem.

I can double check OS versions, etc if you want.
User avatar
Dave B
Jedi Poster
Posts: 5718
Joined: Thu Apr 03, 2003 12:00 am
Location: Maidenhead
Veni, Vidi, Aesculi (I came, I saw, I conkered)

Re: Korg Wavestation instability in Logic Pro X?

Postby Kevin Nolan » Fri Aug 24, 2018 3:02 pm

Unfortunately, it’s crashing Logic every time for me. I’m on High Sierra, LPX 10.4.1, Korfg Collection - latest versions of all of those. All other Korg Collection plugins work perfectly, but Wavestation crashes logic, every time it’s instantiated.
Kevin Nolan
Frequent Poster
Posts: 814
Joined: Sun Jan 12, 2003 1:00 am

Re: Korg Wavestation instability in Logic Pro X?

Postby fatbenelton » Sat Aug 25, 2018 2:37 pm

Not used mine for a while so thought I'd give it a try. It seems ok but I'm I'm merely setting up a stereo instance and noodling - no recording etc but works fine. OS 10.13.6 and Logic 10.4.1......No crashes at all but not exactly deeply testing it!
User avatar
fatbenelton
Frequent Poster
Posts: 630
Joined: Thu Aug 22, 2002 12:00 am
Location: Liverpool, UK
Jonny

Re: Korg Wavestation instability in Logic Pro X?

Postby Kevin Nolan » Sat Aug 25, 2018 9:14 pm

I'm just using a stereo instance too - nothing deep on this end - just - every other of the 200 plugins I own work - but Wavestation - the moment I instantiate it - Logic - Puff!!!!

Completely unusable.
Kevin Nolan
Frequent Poster
Posts: 814
Joined: Sun Jan 12, 2003 1:00 am

Re: Korg Wavestation instability in Logic Pro X?

Postby Rich Hanson » Sun Aug 26, 2018 1:37 pm

fatbenelton wrote:Not used mine for a while so thought I'd give it a try. It seems ok but I'm I'm merely setting up a stereo instance and noodling - no recording etc but works fine. OS 10.13.6 and Logic 10.4.1......No crashes at all but not exactly deeply testing it!

Just checked mine too, doing much the same and so far no problem. (2017 iMac, 21.5" retina, if it might be relevant)
Rich Hanson
Frequent Poster (Level2)
Posts: 2226
Joined: Sat Sep 06, 2003 12:00 am
Location: UK

Re: Korg Wavestation instability in Logic Pro X?

Postby Kevin Nolan » Sat Sep 01, 2018 5:39 pm

Just got a reply from Korg UK with a solution. Probably should have tried this but it didn't occur to me:

1. Reinstall the KORG Collection software.
2. Delete the following AU plug-in cache: ~/Library/Caches/AudioUnitCache
3. Rescan the plugins using Logic's Plugin Manager.

As an aside - I find Korg UK support (which covers Ireland too) to be _absolutely_ fantastic. I've had a lot of dealings with them in the past couple of years and every time they have been incredibly friendly and hugely helpful. From buying spare parts to technical support - just brilliant every time. Just thought it worth flagging.

Kevin.
Kevin Nolan
Frequent Poster
Posts: 814
Joined: Sun Jan 12, 2003 1:00 am

Re: Korg Wavestation instability in Logic Pro X?

Postby ConcertinaChap » Sat Sep 01, 2018 7:55 pm

Good to know as the owner of some Korg kit. Off-topic but quick call out for Softube support, who are both friendly and very effective. Needed them badly recently and they delivered the goods.

CC
User avatar
ConcertinaChap
Jedi Poster
Posts: 9401
Joined: Wed Jul 20, 2005 12:00 am
Location: Bradford on Avon
Making music: Eagle Alley, recording music: Mr Punch's Studio
A full wine rack is a happy wine rack.
 

Previous