You are here

Odd SSD Failure

Page 1 of 1

Odd SSD Failure

PostPosted: Mon Sep 09, 2019 8:18 pm
by Rich Hanson
Last night my MacBook started stuttering and intermittently not responding until it ground to a total halt. On turning it off and on again, it waited ages before giving me the dreaded folder with a question mark.

"Oh bugger, the SSD has died", I think.

This evening I take the SSD out and on a whim connect it through a USB3 to SATA converter and turn the computer on and... it boots.

"Oh bugger, the SATA controller has died", I think.

I turn it off, put the backup HD inside the MacBook and turn it on and... it boots.

So, I now have an SSD that fails when connected internally but works ok when connected through an adapter.

Any idea what might be going on here?

Re: Odd SSD Failure

PostPosted: Tue Sep 10, 2019 9:17 am
by BJG145
I've found a couple of similar cases but no clear answers; eg here and here.

There's a limited number of variables I guess; different cable/port/firmware/image. I suspect re-imaging it might be the answer.

Re: Odd SSD Failure

PostPosted: Tue Sep 10, 2019 9:22 am
by Rich Hanson
I tried that but when the SSD is connected internally the OS sees it but refuses to work with it.

I'm not going to expend too much energy on it right now, so I've just imaged a 1TB hard drive and slapped that in there for the time being.

And right now I'm glad that I've been keeping decent backups :)

Re: Odd SSD Failure

PostPosted: Wed Sep 11, 2019 12:58 am
by cyrano.mac
I'll bet you it's the SATA cable slowly failing...