You are here

Impact LX88+ cutting out

For current or would-be users of Apple Mac computers, with answers to many FAQs.

Impact LX88+ cutting out

Postby DanielBeach » Wed May 13, 2020 8:10 pm

Hi people,

I'm using Logic 10.5 on Catalina with an Impact LX88+ controller.

(By the way, this problem existed before the upgrade yesterday to Logic 10.5)

Everything's been working well for three or four years - all of a sudden, I now have an issue where the Impact stops sending any messages to the Mac/Logic after about two minutes of playing.

I've tried switching midi ports, using hub and plugging directly into the Mac, but it's still the same.

Anybody any ideas?

Thanks,

Daniel
DanielBeach
Regular
Posts: 62
Joined: Sat Sep 14, 2002 12:00 am

Re: Impact LX88+ cutting out

Postby resistorman » Thu May 14, 2020 2:13 am

Have you tried it on another computer or device? If you haven’t tried a hard reset, here’s how...

http://support.nektartech.com/s.nl/ctyp ... /KB.533/.f
User avatar
resistorman
Frequent Poster
Posts: 842
Joined: Sun Nov 22, 2015 1:00 am
Location: Asheville NC

Re: Impact LX88+ cutting out

Postby DanielBeach » Thu May 14, 2020 12:24 pm

Many thanks - yes I have done the hard reset but to no avail.

I’ll try another new lead just in case.
DanielBeach
Regular
Posts: 62
Joined: Sat Sep 14, 2002 12:00 am

Re: Impact LX88+ cutting out

Postby DanielBeach » Thu May 14, 2020 1:53 pm

Solved - for anybody who may have similar problems in Logic, it seemed that the control surface 'driver' had duplicated itself in Logic somehow. Once I deleted one instance of it and rebooted, fingers crossed, everything seems to be fine now.

Daniel
DanielBeach
Regular
Posts: 62
Joined: Sat Sep 14, 2002 12:00 am