You are here

Ambisonic Sound Library files by RØDE and Logic Pro X 10.5.1

For current or would-be users of Apple Mac computers, with answers to many FAQs.

Ambisonic Sound Library files by RØDE and Logic Pro X 10.5.1

Postby Richfield006 » Sun Sep 20, 2020 2:39 pm

Hi,
I am currently struggling playing with example ambisonic files on Røde website (https://library.soundfield.com) in Logic Pro 10.5.1. When I import the downloaded file onto Logic Pro X, it just separates in 4 mono track and and when I insert the SoundField by Rode Plugin in the master bus, I don't get the proper A-format out. I then searched the web and came across this article which helped me in resolving the issue (https://www.soundonsound.com/techniques ... onic-audio) in which I panned the way what the article suggested - Got the A-format input and then outputted to Stereo, 5.1 and other outs inside the SoundField Plugin !!!(Problem Solved) . But this is where things got even more excited. Just to double check, I used the same Poly WAV file in Reaper 6.13. The files did not separate to individual tracks and it was all in 1 single track and I didn't even pan them. When I inserted the Rode SoundField plugin on Master Out, the A-format out I got from Reaper was different from Logic. Now, I am really confused of which on of those is true. And this made me to research more about ambisonics and Rode Mic where they do not mention which order the WXYZ information is captured. Could you please help me in this regards? or am I missing something obvious
Thank You
Richfield006
Posts: 1
Joined: Sun Sep 20, 2020 2:25 pm

Re: Ambisonic Sound Library files by RØDE and Logic Pro X 10.5.1

Postby ConcertinaChap » Wed Sep 23, 2020 7:14 am

Hi. I regret I have no experience with Reaper, however I would say that Reaper seems to be the DAW of choice amongst the developers of ambisonic hardware and software because it seems to handle A and B format better, especially for higher order ambisonics which Logic can't handle at all.

I'm glad you found my article helpful though I'm a bit startled that you're having to use the workaround again. Apple fixed the bug in 10.4.5. I wonder if it has reappeared in 10.5, I'll have a look.

Cheers,

CC
User avatar
ConcertinaChap
Jedi Poster
Posts: 9109
Joined: Tue Jul 19, 2005 11:00 pm
Location: Bradford on Avon
Making music: Eagle Alley, recording music: Mr Punch's Studio
A full wine rack is a happy wine rack.
 

Re: Ambisonic Sound Library files by RØDE and Logic Pro X 10.5.1

Postby ConcertinaChap » Tue Oct 06, 2020 12:41 pm

Sorry I didn't get back before, I got rather caught up finishing our forum album track.

Well I created a project in Logic 10.5.1 set up for ambisonics (more precisely I used the template I described in the article) and imported the Rode jazz.wav file. It imported fine and I was able to work with it, e.g. using the Dear Ambi Micro plugin after the Soundfield plugin to generate binaural output. So I don't really know why you're having problems, I'm afraid.

CC
User avatar
ConcertinaChap
Jedi Poster
Posts: 9109
Joined: Tue Jul 19, 2005 11:00 pm
Location: Bradford on Avon
Making music: Eagle Alley, recording music: Mr Punch's Studio
A full wine rack is a happy wine rack.