You are here

Logic won't launch - Mac mini mid 2011

For current or would-be users of Apple Mac computers, with answers to many FAQs.

Moderator: Moderators

Logic won't launch - Mac mini mid 2011

Postby DAN » Thu Dec 03, 2020 9:35 am

Hi guys,

It was all working well until a couple of weeks ago, now Logic (or iMovie) won't launch,

I have a mid 2011 Mac mini with 16 gig ram running High Sierra 10.13.6

I have tried erasing the hard disk and reinstalling, and have just bought a new hard drive but still the same problem persists.

All I get is a crash report:

Process: Logic Pro X [803]
Path: /Applications/Logic Pro X.app/Contents/MacOS/Logic Pro X
Identifier: com.apple.logic10
Version: ???
Build Info: MALogic-5182000000000000~3
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Logic Pro X [803]
User ID: 501

PlugIn Path:
PlugIn Identifier:
PlugIn Version: ??? (551.5)

Date/Time: 2020-12-03 09:31:47.066 +0100
OS Version: Mac OS X 10.13.6 (17G14042)
Report Version: 12
Anonymous UUID: 96CA20BD-8E8E-196F-4510-D59CD49F624E


Time Awake Since Boot: 1300 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_CRASH (Code Signature Invalid)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Reason: Namespace CODESIGNING, Code 0x1

kernel messages:

VM Regions Near 0 (cr2):
-->
__TEXT 0000000100809000-00000001024dd000 [ 28.8M] r-x/rwx SM=COW 

Thread 0 Crashed:
0 0x000000010f6aa19c _dyld_start + 0

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000000000000000 rbx: 0x0000000000000000 rcx: 0x0000000000000000 rdx: 0x0000000000000000
rdi: 0x0000000000000000 rsi: 0x0000000000000000 rbp: 0x0000000000000000 rsp: 0x00007ffeef3f6c38
r8: 0x0000000000000000 r9: 0x0000000000000000 r10: 0x0000000000000000 r11: 0x0000000000000000
r12: 0x0000000000000000 r13: 0x0000000000000000 r14: 0x0000000000000000 r15: 0x0000000000000000
rip: 0x000000010f6aa19c rfl: 0x0000000000000200 cr2: 0x0000000000000000

Logical CPU: 0
Error Code: 0x00000000
Trap Number: 0


Binary Images:
0x100809000 - 0x1024dcff7 + (5182) <BA7CB7F8-DEDB-38F3-807D-8820349052DA>
0x10f6a9000 - 0x10f6f3adf + (551.5) <CB9BFB56-4511-36F1-A546-891FF770C01C>

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 1
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 876
thread_create: 0
thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=31.9M resident=0K(0%) swapped_out_or_unallocated=31.9M(100%)
Writable regions: Total=9.9M written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=9.9M(100%)

VIRTUAL REGION
REGION TYPE SIZE COUNT (non-coalesced)
=========== ======= =======
STACK GUARD 56.0M 2
Stack 8192K 2
__DATA 5724K 5
__LINKEDIT 2824K 3
__TEXT 29.1M 3
shared memory 8K 3
=========== ======= =======
TOTAL 101.5M 12

Model: Macmini5,1, BootROM 135.0.0.0.0, 2 processors, Intel Core i5, 2.3 GHz, 16 GB, SMC 1.76f0
Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1333 MHz, 0x859B, 0x435438473353313333394D2E4D3136464544
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1333 MHz, 0x859B, 0x435438473353313333394D2E4D3136464544
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xE4), Broadcom BCM43xx 1.0 (5.106.98.102.30)
Bluetooth: Version 6.0.7f22, 3 services, 27 devices, 1 incoming serial ports
Network Service: Ethernet, Ethernet, en0
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: CT240BX500SSD1, 240.06 GB
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: 2.4G Receiver
USB Device: USB 3.0
USB Device: IR Receiver
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: Microsoft® Digital Media Keyboard
USB Device: USB to ATA/ATAPI bridge
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
Thunderbolt Bus: Mac mini, Apple Inc., 22.2


Can anyone shed any light on this?

Many thanks in advance,

Dan
DAN
Regular
Posts: 65
Joined: Thu Sep 11, 2003 12:00 am
Location: Dordogne, France.

Re: Logic won't launch - Mac mini mid 2011

Postby desmond » Thu Dec 03, 2020 1:21 pm

That's a codesigning problem - the code signature of the app is failing.

Have you installed any third-party plugins in the past few weeks?
User avatar
desmond
Jedi Poster
Posts: 10840
Joined: Tue Jan 10, 2006 1:00 am
mu:zines | music magazine archive | difficultAudio

Re: Logic won't launch - Mac mini mid 2011

Postby DAN » Thu Dec 03, 2020 6:39 pm

desmond wrote:That's a codesigning problem - the code signature of the app is failing.

Have you installed any third-party plugins in the past few weeks?

Hi Desmond, no I haven't installed any 3rd party plugins for a couple of years
DAN
Regular
Posts: 65
Joined: Thu Sep 11, 2003 12:00 am
Location: Dordogne, France.

Re: Logic won't launch - Mac mini mid 2011

Postby desmond » Thu Dec 03, 2020 6:52 pm

There have been a handful of code signing-related crashes on the forums over the past few weeks, I'm wondering if there is a general Apple related issue (some certificate has expired somewhere or something).

There is a brute-force approach to potentially fixing it by replacing the code signing with a self-signed cert, but I don't really want to go there just yet and you shouldn't have to.

You said other apps than Logic are also crashing in the same way - with the same code sign error?

If you start Logic and hold "control" while it's loading, then choose to not launch the Core Audio driver, will Logic load then?
User avatar
desmond
Jedi Poster
Posts: 10840
Joined: Tue Jan 10, 2006 1:00 am
mu:zines | music magazine archive | difficultAudio

Re: Logic won't launch - Mac mini mid 2011

Postby DAN » Sat Dec 05, 2020 1:40 pm

desmond wrote:There have been a handful of code signing-related crashes on the forums over the past few weeks, I'm wondering if there is a general Apple related issue (some certificate has expired somewhere or something).

There is a brute-force approach to potentially fixing it by replacing the code signing with a self-signed cert, but I don't really want to go there just yet and you shouldn't have to.

You said other apps than Logic are also crashing in the same way - with the same code sign error?

If you start Logic and hold "control" while it's loading, then choose to not launch the Core Audio driver, will Logic load then?

Hi Desmond,

Yes, iMovie won't launch either, and I get the same Crash Report
DAN
Regular
Posts: 65
Joined: Thu Sep 11, 2003 12:00 am
Location: Dordogne, France.

Re: Logic won't launch - Mac mini mid 2011

Postby G-Doubleyou » Sun Dec 06, 2020 6:18 pm

Try running disk repair with the disk utility.

:thumbup:
User avatar
G-Doubleyou
Frequent Poster
Posts: 970
Joined: Fri Feb 10, 2006 1:00 am
G-Dub Studio G-fx 2011 15inch 2.0GHz quad-core i7 Macbook Pro, LPX 10.3.2
2.3 GHz quad-core i7 Mini