You are here

Dell XPS15 L502X - Latency Problem

For anything relating to music-making on Windows computers, with lots of FAQs. Moderated by Martin Walker.

Dell XPS15 L502X - Latency Problem

Postby takubayashi » Wed Apr 13, 2011 10:58 pm

I've just bought the above laptop on a wing and a prayer (without research) since it has Sandy Bridge CPU and ace screen. I was rather hoping that due to all of its power latency wouldn't be a problem... My soundcard is Octa Capture and DAW Sonar X1.

During initial tweaking I found regular spikes on DPC latency software into yellow and red. However, having disabled the wifi card there was a big improvement and with a few more disablements the checker reports on average 80 - 150 (nano?)s latency which is pretty good by all accounts and the same as another desktop system I have which has no issues with low latency tracking.

The problem here is that while DPC is reported as low, actual audio performance in X1 is atrocious and there a pops and clicks aplenty even with playback of small projects which I'm at a loss to explain. In addition to the above I've tried the following:

1. minimum CPU speed to 100%
2. power management settings to always on when plugged in.

I'm struggling to think what else to try and the Bios doesn't hold many promising options. Please advise asap so I can keep the option of sending it back if there is no hope.

Thanks
User avatar
takubayashi
Poster
Posts: 26
Joined: Sat Dec 10, 2005 1:00 am

Re: Dell XPS15 L502X - Latency Problem

Postby The Korff » Wed Apr 13, 2011 11:20 pm

Have you set processor scheduling to prioritise 'Background Tasks'? Some ASIO-driver interfaces respond well to this. (I forget where the option for this is... On Windows XP it always used to be right-click My Computer/Properties/Advanced, or something.)

Failing that, on my Dell XPS M1710 there's a BIOS option to disable the onboard card reader, which might free up some further system resources/motherboard bus bandwidth. Some of the more esoteric sound cards also like Intel Speedstepping to be either enabled or disabled (again, I forget which way round it is!), so that might be worth a shot too.

Hope that helps!

Chris
The Korff
Frequent Poster (Level2)
Posts: 2201
Joined: Fri Jan 08, 2010 12:28 pm
Location: The Wrong Precinct

Re: Dell XPS15 L502X - Latency Problem

Postby takubayashi » Wed Apr 13, 2011 11:31 pm

Thanks

I have tried the background processes thing to no avil, not yet the speedstep which is currently off but the card may prefer off. Did you manage to get your Dell laptop working reliably?
User avatar
takubayashi
Poster
Posts: 26
Joined: Sat Dec 10, 2005 1:00 am

Re: Dell XPS15 L502X - Latency Problem

Postby takubayashi » Wed Apr 13, 2011 11:32 pm

currently on but the card may prefer off...
User avatar
takubayashi
Poster
Posts: 26
Joined: Sat Dec 10, 2005 1:00 am

Re: Dell XPS15 L502X - Latency Problem

Postby The Korff » Wed Apr 13, 2011 11:56 pm

I haven't really tested my XPS for audio yet - I only just fixed it! My colleague has one though, and he said he'd been struggling with it too... I'll ask him to post tomorrow though, to see if he managed to get it running smoothly.

Cheers!

Chris
The Korff
Frequent Poster (Level2)
Posts: 2201
Joined: Fri Jan 08, 2010 12:28 pm
Location: The Wrong Precinct

Re: Dell XPS15 L502X - Latency Problem

Postby Sam Inglis » Tue Apr 19, 2011 3:57 pm

My XPS 1710 has never been particularly audio friendly. Not that it falls over or anything, but it really doesn't like running at low latencies. Even 1024 samples imposes a noticeable CPU load and I think I've only ever found one interface that could run at 256 without dropouts. Upgrading from XP to Windows 7 doesn't seem to have made much difference.
Sam Inglis
Moderator
Posts: 2653
Joined: Fri Dec 15, 2000 1:00 am

Re: Dell XPS15 L502X - Latency Problem

Postby takubayashi » Sun Apr 24, 2011 4:07 pm

Thanks Sam

After a bit of playing around I've got round trip latency down to a reported 20ms in Sonar X1. This is on an asio buffer setting of 128 in the driver. Confusingly X1 reports the input latency as 7.1ms based on a buffer of 311 - not sure where that's coming from. Anyway, whatever the actual latency live playing with effects is fine (and stable) on these settings which is what I was going for.

I still get popping on big demo projects. The wifi driver is particularly bad for dpc although I can now get stable throughput even with that enabled.

Various new drivers have come out since I got the machine and I've been updating and tried to remove bloatware installed by Dell. I'm optimistic that I can further improve stablility by continued effort although my consumer tendencies could see me sabotaging myself. I've added live mesh and sugar sync - I don't imagine these are overly audio friendly although they've not caused any problems so far. In theory I guess this CPU is probably powerful enough to do loads of things at the samed time - so long as they dont screw up dpc

Any hints on general things to optimise laptops for audio most welcome.
User avatar
takubayashi
Poster
Posts: 26
Joined: Sat Dec 10, 2005 1:00 am

Re: Dell XPS15 L502X - Latency Problem

Postby Exalted Wombat » Sun Apr 24, 2011 5:19 pm

Yes, laptops and multitrack recording - well, let's just say "don't work on a laptop unless you HAVE to" :-(

See how it performs running on battery instead of plugged in. And how it does running on mains with the battery removed.

I hadn't come across the Octa Capture, but looking at the web page I see it offers "...Four independent software-controlled Direct Mixers for creating custom monitor mixes". So do you NEED a particularly low latency figure within the DAW?

One last thought - you're not doing anything silly like trying to record at higher than 44.1KHz (or 48KHz if you work in video) are you?
Exalted Wombat
Jedi Poster
Posts: 5730
Joined: Sat Feb 06, 2010 1:00 am
Location: London UK
You don't have to write songs. The world doesn't want you to write songs. It would probably prefer it if you didn't. So write songs if you want to. Otherwise, dont bore us with beefing about it. Go fishing instead.