You are here

Hard drive interference

For anything relating to music-making on Windows computers, with lots of FAQs. Moderated by Martin Walker.

Hard drive interference

Postby Gary_W » Fri Apr 29, 2011 8:30 pm

Hello all,

I haven't recorded in ages (life is like that) but have a few things written and am keen to crack on. Part of this is going to be treating the room here (it's very lively and nothing has sounded spot on since we moved in, so I'll be doing some DIY with the rockwool very soon). I also re-built my PC a few months back and went Windows 7. Oh, and I've just ordered a Liquid Mix 16. But don't tell anyone!

Everything is fine except for the fact that the new hard drive seems to spin and access nearly constantly! It's not THAT noisey, but what it does seem to do is to play havoc with single coil guitars! I am fortunate enough to have a lovely Matamp C7 guitar amp and, provided I have a humbucker equiped guitar, the hard drive access thing does not bother it. As soon as I put on my Strat, it picks up the noise!

I have taken the Strat to bits and turkey foiled everything. Whilst this has given huge benefits in terms of overall noise level, it still 'hears' the hard drive!

Any thoughts on:-

a) Why the drive spins all the time? (no obvious background programs causing it to do so)

b) How I can stop it?

c) If this is 'normal for Windows 7' or for this type of drive, can I screen it a bit better?

It's one of the super-fast Western Digital jobbies. I cannot recall the exact model, but I'm willing to whip it out (ooer missus) if that's needed to shed light on this. The case is a nice big, well-earthed Antec and it has been in use for several years. None of the other hard drives do this!

Any thoughts gratefully received :)

Thanks

Gary
Gary_W
Regular
Posts: 433
Joined: Wed Oct 18, 2006 12:00 am

Re: Hard drive interference

Postby Exalted Wombat » Fri Apr 29, 2011 8:56 pm

W7 can get busy with the hard drives until initial indexing is completed. It generally knows how to get out of the way when another application wants the disk, but when NOT recording it may grab the chance. Various settings can be made in Control Panel/Indexing Options.

Years ago, using an Atari, I had to switch the video monitor off and record "blind" due to interference. If it IS the disk being picked up, minimising activity won't help as the disk HAS to be active while you're recording. But I'm wondering. Go to Network & Sharing Centre/Adapter Settings and disable your LAN adapter (and any other network ports, wired or wireless). ANy better?
Exalted Wombat
Jedi Poster
Posts: 5730
Joined: Sat Feb 06, 2010 1:00 am
Location: London UK
You don't have to write songs. The world doesn't want you to write songs. It would probably prefer it if you didn't. So write songs if you want to. Otherwise, dont bore us with beefing about it. Go fishing instead.

Re: Hard drive interference

Postby Gary_W » Fri Apr 29, 2011 9:40 pm

Thanks for your reply.

I went and had a look at indexing and it was turned off! According to Mr. Google, this is the default setting....

I've turned it on. Hard drive activity doesn't seem to have differed so far (as in nothing, then a burst for no apparant reason when I'm doing nowt). However, it'll be interesting to see if I see any difference over the next day or two so many thanks for the suggestion :)

I've also just tried recording a little bit in Reaper and you are correct that the hard drive accessing calms down, but it still has a little blip or tick every so often (which is to be expected). Unfortunately, every time one of these little ticks happens, you can hear it via a single coil pickup and it comes through on the Matamp. As I mic that up, it'll be on the recording :frown:

I have excluded the amp from the equation as the single coil guitar will also give this problem going straight into my recording interface with Guiar Rig....

As to the accessing of the drive, I should also point out that I have 12 gig of RAM and it's an Intel Core i7 so I don't think the poor dear is running out of memory and having to constantly jot stuff down on the drive. The drive that is giving the problems is the one that the operating system and everything else is sat on.... It's a 1TB drive and it's about 1/2 full. It defrags automatically once a week and has no errors.

Gary
Gary_W
Regular
Posts: 433
Joined: Wed Oct 18, 2006 12:00 am