You are here

USB drives going to sleep

For anything relating to music-making on Windows computers, with lots of FAQs. Moderated by Martin Walker.

USB drives going to sleep

Postby twotoedsloth » Sun Apr 08, 2018 12:28 am

Hello,

I just upgraded my PC, and I'm trying to remember a setting. My external USB hard drive seems to keep going to sleep. I remember I changed a setting somewhere with my old computer, but I can't find it now.

I'm running a 3.7 gHz 8 core Xeon with 32 gigs of RAM and my external drive is a Glyph USB 3 mechanical hard disc, my OS is Windows 10.

Thanks,
Peter
twotoedsloth
Frequent Poster
Posts: 778
Joined: Sat Jan 26, 2008 12:00 am

Re: USB drives going to sleep

Postby ef37a » Sun Apr 08, 2018 4:43 am

I have an ND-XS NAS drive that also has a USB port (not connected) and that has a sleep function* that can be accessed via a "Freecom" app. The IP address is 192.168.1.8 and that might be a generic address for such drives?

*I set mine to drop off after 10 minutes inactivity and not to run up until called, takes about 10 secs to wake up, because if left 'spinning' the drive got bloody hot! In fact I mounted it an oversized ally chassis to further heat sink it.

Something like Belarc Advisor might ID the drive for you?

Dave.
ef37a
Jedi Poster
Posts: 9061
Joined: Sun May 28, 2006 11:00 pm
Location: northampton uk

Re: USB drives going to sleep

Postby wireman » Sun Apr 08, 2018 11:10 am

Look at the power options in Control Panel.
wireman
Regular
Posts: 102
Joined: Fri Dec 17, 2004 12:00 am

Re: USB drives going to sleep

Postby twotoedsloth » Mon Apr 09, 2018 6:56 pm

Hello,

I've tried all of the power options in the control panel. For some reason it does not remember my changes. I will save and exit, then reboot and it's back to "balanced" from "high performance".

Also, can I disable USB Selective Suspend safely?
twotoedsloth
Frequent Poster
Posts: 778
Joined: Sat Jan 26, 2008 12:00 am

Re: USB drives going to sleep

Postby wireman » Mon Apr 09, 2018 7:49 pm

twotoedsloth wrote:Hello,

I've tried all of the power options in the control panel. For some reason it does not remember my changes. I will save and exit, then reboot and it's back to "balanced" from "high performance".

Also, can I disable USB Selective Suspend safely?

I thought this might happen. I found a few similar complaints but thought it worth just trying the obvious first. Perhaps one of the threads below will give you a clue

thread1
thread2
thread3

And don't have any unfounded expectation from the "answers" in answers.microsoft.com, some of the people who "help" on these forums provide advice that is not appropriate to the issue at hand.
wireman
Regular
Posts: 102
Joined: Fri Dec 17, 2004 12:00 am

Re: USB drives going to sleep

Postby CS70 » Mon Apr 09, 2018 8:17 pm

twotoedsloth wrote:Hello,

I just upgraded my PC, and I'm trying to remember a setting. My external USB hard drive seems to keep going to sleep. I remember I changed a setting somewhere with my old computer, but I can't find it now.

I'm running a 3.7 gHz 8 core Xeon with 32 gigs of RAM and my external drive is a Glyph USB 3 mechanical hard disc, my OS is Windows 10.

Thanks,
Peter

Go to the device manager, right click on all the USB devices and uncheck "allow pc to manage power this device" or something like that.
User avatar
CS70
Frequent Poster (Level2)
Posts: 2549
Joined: Mon Nov 26, 2012 12:00 am
Location: Oslo, Norway
Silver Spoon - Check out our latest video  and the FB page

Re: USB drives going to sleep

Postby Watchmaker » Tue Apr 10, 2018 5:24 am

From your desktop, right click on “My Computer” or “this PC”, select “manage” from the menu. When the Computer Manager window loads, select “device manager”. In the right hand window you'll see a list of components.

Find “USB Serial Bus Controllers” (or similar), towards the bottom of the list and click the little plus sign or triangle next to it. That will show another detailed list of every USB root hub on your machine. For every controller with the words “root hub” in it's description, right click and select "properties" at the bottom of the menu. In the window that opens, find the power management tab, look down, un-click “allow computer to turn of this device to save power” close the window. Do this for all of 'em. Should do the trick.

I also go to the power management via Control panel and change power settings. Power Options>change plan settings> change advanced power settings>USB settings>USB selective suspend=disabled.
User avatar
Watchmaker
Regular
Posts: 132
Joined: Tue Apr 12, 2016 11:00 pm
"one feels most reassured hearing an expert's opinions on the matter..."

Re: USB drives going to sleep

Postby twotoedsloth » Thu Apr 12, 2018 4:39 pm

This is really getting frustrating. All of these changes work until I reboot.

Then it goes back to the previous "balanced" settings. Even the changes in device manager...

Any ideas?
twotoedsloth
Frequent Poster
Posts: 778
Joined: Sat Jan 26, 2008 12:00 am

Re: USB drives going to sleep

Postby CS70 » Thu Apr 12, 2018 5:06 pm

twotoedsloth wrote:This is really getting frustrating. All of these changes work until I reboot.

Then it goes back to the previous "balanced" settings. Even the changes in device manager...

Any ideas?

Which OS version?
User avatar
CS70
Frequent Poster (Level2)
Posts: 2549
Joined: Mon Nov 26, 2012 12:00 am
Location: Oslo, Norway
Silver Spoon - Check out our latest video  and the FB page

Re: USB drives going to sleep

Postby ef37a » Thu Apr 12, 2018 5:08 pm

Total numpty here but can't it be set in 'Hardware Profiles' ?

Dave.
ef37a
Jedi Poster
Posts: 9061
Joined: Sun May 28, 2006 11:00 pm
Location: northampton uk

Re: USB drives going to sleep

Postby twotoedsloth » Mon Apr 16, 2018 7:26 pm

Well, after more than a week of frustration, I just bought a second internal hard disc, 12 terabytes, just $500. This should last me a while, and I can use the external drive for backups. It's a shame because I paid a premium to get the "high performance" Glyph drive, and I can't take advantage of that, but such is life.

Thanks for your help, kind folks.
twotoedsloth
Frequent Poster
Posts: 778
Joined: Sat Jan 26, 2008 12:00 am


Who is online

Users browsing this forum: No registered users