You are here

Latest Reaper Update Error Message...

Page 1 of 1

Latest Reaper Update Error Message...

PostPosted: Wed Sep 19, 2018 6:59 pm
by The Bunk
I've just carried out the latest Reaper update and I'm getting an error message repeatedly: "The following MIDI inputs could not be opened: USN Uno MIDI Interface".
I use the "retry" option; nothing happens, it reappears.
I close the message window...all good and the song already loaded plays normally. So it doesn't actually affect anything, it's just a PITA, and a little disconcerting.

I haven't got anything that I can see that correlates to this. Interface is a Focusrite 2i2 and I have in the past, but not currently, connected a Juno-D midi keyboard. But there is nothing currently plugged into the Focusrite.

Anyone else...? And anything to worry about?

Re: Latest Reaper Update Error Message...

PostPosted: Wed Sep 19, 2018 7:37 pm
by Martin Walker
Have you tried rebooting?

Yes, I know that's a classic thing to suggest, but I recently got a 'can't open MIDI port' error message from Reaper and it turned out to be simply that the interface with this MIDI port needed re-initialising for some reason, and after a reboot it reappeared none the worse for wear ;)

I also managed to cure this one in one case by logging off from Windows, and then logging back in, once again to re-initialise the audio interface in question.

Worth a try anyway, although the fact that you get errors about a 'USN Uno MIDI Interface' does suggest that your computer thinks it has drivers for said interface installed but not fulyl functioning - if you find these in Device Manager then you can uninstall them.


Martin

Re: Latest Reaper Update Error Message...

PostPosted: Wed Sep 19, 2018 9:49 pm
by James Perrett
I wonder if this is related to

+ MIDI devices: provide separate options to show warnings for non-present MIDI devices vs devices which could not be opened

(from the change log to the current version).

Re: Latest Reaper Update Error Message...

PostPosted: Thu Sep 20, 2018 6:53 am
by ef37a
Eh'up! PC numpty about to opine...

The 2i2 does not have MIDI ports but could it be that the 2i2 driver is just "generic" to the range and Windows thinks there should be MIDI connections but cannot find them?

This would align Microsoft with MY philosophy that an audio interface is not really "proper" without MIDI ports!

Dave.

Re: Latest Reaper Update Error Message...

PostPosted: Thu Sep 20, 2018 11:40 am
by blinddrew
Plug the Juno back in and try again. I have a few midi devices connnected to Reaper and if one of them isn't of, or fails to boot properly, it throws up a similar message.
Once it's found what it's looking for the first time (post update) it will probably be fine from then on.

Re: Latest Reaper Update Error Message...

PostPosted: Thu Sep 20, 2018 6:04 pm
by The Bunk
Thanks guys; the re-boot was the first thing I tried actually and it didn't work, although this has happened in the past and it did.
Anyhow, somehow some way I've solved it, most probably by accident...! I actually tried a few things yesterday at first but after each failed attempt, I quite Reaper without saving the project. This time, I just randomly clicked a few options but "saved" when exiting, and hey presto, it's gone.

I reckon a highly remunerative IT job in The City beckons....

Re: Latest Reaper Update Error Message...

PostPosted: Thu Sep 20, 2018 11:37 pm
by Martin Walker
Glad you're sorted anyway The Bunk - let's let this one remain a mystery and move one ;)


Martin