You are here

Driver, getting shot of

For anything relating to music-making on Windows computers, with lots of FAQs. Moderated by Martin Walker.

Driver, getting shot of

Postby ef37a » Sun Dec 29, 2019 1:17 pm

I have just put Reaper on my W10 Lenovo T510 laptop and it refuses to find the correct ASIO driver for my UMC204HD, instead I get 'MAGIX Low Latency 2016' which is effectively ASIO4all.

I have seached Drivers in W10 as best I can but cannot find 'MAGIX...' or ASIO4all. I previously installed a trial of Samplitude ProX 4 and I guess this is the root of the problem. But, I have several Samplitudes on this W7 HP lappy AND Reaper and I can set it to the correct Behringer ASIO driver no problem.

Naturally I am very wary of deleting drivers unless I am sure I have the right one, also W10 is apallingly difficult to navigate to do these sort of tasks!

Last resort I suppose is to uninstall Pro X4 but I am not sure they will give me another go!

Dave.
ef37a
Jedi Poster
Posts: 11287
Joined: Mon May 29, 2006 12:00 am
Location: northampton uk

Re: Driver, getting shot of

Postby Pete Kaine » Thu Jan 02, 2020 2:45 pm

ef37a wrote:I have just put Reaper on my W10 Lenovo T510 laptop and it refuses to find the correct ASIO driver for my UMC204HD, instead I get 'MAGIX Low Latency 2016' which is effectively ASIO4all.

I have seached Drivers in W10 as best I can but cannot find 'MAGIX...' or ASIO4all.

Sorry, are you talking about using the Microsoft driver repository to download them, or have you already installed the proper drivers and it just can't see them?

Native drivers that appear in Microsofts own driver repository have to be WHQL certified which costs money and I don't see the one man band that is A4A having the time, money or patience of navigating the MIcrosoft submission system 3 or 4 times a year.

Just so I'm clear, you've tried the ones found here?

https://www.behringer.com/Categories/Be ... /Downloads

ef37a wrote:I previously installed a trial of Samplitude ProX 4 and I guess this is the root of the problem. But, I have several Samplitudes on this W7 HP lappy AND Reaper and I can set it to the correct Behringer ASIO driver no problem.

Previously or still are? If it's timed out then it might be locking up other parts of the sub-system (it shouldn't be, but I've seen other peices of code manage to screw up in similar fashion) although, I guess if the trail had already expired you wouldn't be concerned about removing it.

ef37a wrote:Naturally I am very wary of deleting drivers unless I am sure I have the right one, also W10 is apallingly difficult to navigate to do these sort of tasks!

The Behringer as it installs serprately (assuming it does? I could have sworn that some of those cheaper units just used A4A instead of a dedicated one) should just show in your add/remove options as it's own thing. If the Sampletude driver is built into the software then I guess removing it might work, although it shouldn't really make a difference, the Behringer one if already installed should be completely visable to you already... as should A4A if you've installed it from it's own website too so this is where it gets a bit confusing as it sounds like you can't see any ASIO drivers right now?

Can I ask where exactly you are failing to see these drivers? Is this specifc to Sampletude or across everything? If you bang Reaper on there, what does it pick up?
User avatar
Pete Kaine
Frequent Poster (Level2)
Posts: 3134
Joined: Thu Jul 10, 2003 12:00 am
Location: Manchester
Kit to fuel your G.A.S - https://www.scan.co.uk/shop/pro-audio

Re: Driver, getting shot of

Postby ef37a » Thu Jan 02, 2020 3:09 pm

Thanks Pete,
I have just seen in Windows Sounds settings "You need to activate Windows before you can personalize your PC" That is something I have to take up with the vendor when they return from their junketing. My driver issues might at the moment be a waste of everyone's time?

I chose the 204 HD just because it is the first AI in the range that has proper ASIO drivers and they show up as such on my HP W7 laptop.

I did not get the T510 for any serious audio work so I shall not bother anyone further with this issue. I can let Sam p4 drop out after 3 weeks then clear it all out and have a fresh start.

Dave.
ef37a
Jedi Poster
Posts: 11287
Joined: Mon May 29, 2006 12:00 am
Location: northampton uk

Re: Driver, getting shot of

Postby Agharta » Sat Jan 04, 2020 12:49 am

I had a related issue with that Magix driver that caused issues but not with Reaper.
I Googled it and found a way to disable or remove it but don't recall if I had to uninstall the Magix software that had presumably installed it.
Wish I could be more helpful but do try and search the Web more for info.
Agharta
Frequent Poster (Level2)
Posts: 3892
Joined: Sat Oct 30, 2004 12:00 am