You are here

Can't record audio through any "normal" Windows app but Reaper's fine

For anything relating to music-making on Windows computers, with lots of FAQs. Moderated by Martin Walker.

Can't record audio through any "normal" Windows app but Reaper's fine

Postby AlasdairEaston » Fri Apr 03, 2020 10:04 am

Hi. I'm having a strange problem and I wonder if anyone here can help? I can't seem to record audio using any of the "normal" (i.e. not studio, pro audio) Windows apps.

I'm using a Zoom UAC-8 interface for normal studio recording duties. It's been great. I'm on a Scan pro audio PC running Reaper and all the usual stuff. Works a treat.

However, I need to be able to do video meetings these days and I can't source a decent webcam anywhere (surprise surprise!). I thought, no problem, I'll use my action cam, an Akaso EK7000. And that's exposed the problem. I just can't seem to get "normal" windows apps (like Camera, Voice Recorder, Zoom video meetings, etc.) to receive audio at all. From either my Zoom UAC-8 or my action cam.

Windows audio control panel sees the devices, allows me to check properties, set as default devices, etc. but there's just no audio being received at all (the green meters in the Windows audio properties panel that normaly show the mic signal do not move, always zero). And this despite the Zoom's MixFx mixing software clearly showing the mic signal from my AT2020, and the sound coming out my speakers.

Zoom (the video calling app) allows me to select my mic input and check the signals, and sure enough, no signal from either the action cam or the audio interface.

Again though, if I launch Reaper and hit record, that all works perfectly from the interface.

Has anyone got any insight to offer?

Interestingly, in the action cam audio properties, the recording tab, it won't allow me to move the "levels" slider. It's locked on what it calls 0bB, all the way to the left. This might be a drivers problem for the webcam I guess? Windows (as another thread has pointed out) naturally says the best drivers are already installed.

For the UAC-8 interface that slider works fine, so I might have two seperate problems going on here, with, sadly the same result. No windows audio recording. I've tried moving the sample rate down to 48KHz and 41KHz but it makes no difference.

I'm (easily, it seems!) baffled.

Posts: 39
Joined: Fri Feb 10, 2017 2:17 pm

Re: Can't record audio through any "normal" Windows app but Reaper's fine

Postby Pete Kaine » Fri Apr 03, 2020 1:02 pm

I can possibly explain what's going on, but right now I can't explain why.

Windows applications are running the native Wasapi driver, whilst the audio applications are running the ASIO part of the driver which has its own capability for routing. It sounds like it's set-up correctly within your music applications, but otherwise, there is some sort of disconnect in it talking directly to Windows.

I've not seen this before though in the fashion you're describing, although I would have assumed some kind of routing problem out of the control panel given you've got audio going in and nothing coming out, although I don't know that specific control panel well enough to know if there are any likely changes you could make. Might be worth grabbing snapshots of what windows/zoom panel are doing and forwarding them to Zoom support as it sounds like you have it right, but there could be something not so obvious in there I suppose.
User avatar
Pete Kaine
Frequent Poster (Level2)
Posts: 3185
Joined: Thu Jul 10, 2003 12:00 am
Location: Manchester
Kit to fuel your G.A.S -

Re: Can't record audio through any "normal" Windows app but Reaper's fine

Postby Wonks » Fri Apr 03, 2020 1:19 pm

Does Zoom (video) actually support ASIO drivers?
User avatar
Jedi Poster
Posts: 10894
Joined: Thu May 29, 2003 12:00 am
Location: Reading, UK
Correcting mistakes on the internet since 1853

Re: Can't record audio through any "normal" Windows app but Reaper's fine

Postby AlasdairEaston » Fri Apr 03, 2020 2:22 pm

Pete and Wonks, thanks for the input. I was just coming on to give an update since I've made some slight progress.

I switched on the Loop Back button on the Zoom MixFx software and I was able to record the mic that way.

What led to that was... I was thinking about how the audio stream from the UAC-8 might get to Windows and what it would do with it, and contrasting that with how Reaper would deal with it. For example I can tell Reaper to take input from, say, input 8 on the interface. But what would Windows really know about multi-input audio and how would I tell it to listen to just one input? In other words, what am I really telling it to record if I just tell it to record from the UAC-8? I wasn't sure how that could work without all sorts of "input selection" type tools, and of course Windows itself doesn't offer any of that. So that led me to think about the loop back option in MixFx. I use that if I just want to record (say, in Reaper) whatever sound is currently coming out of the computer at that moment, including the main stereo outs and any inputs too.

So, happily that works, whether my reasoning is sound or not. Pete, it sounds like you were heading in the same sort of direction maybe just from a different way.

Sadly, if I record a short video clip using the action cam for the video and this loop-back-and-mic arrangement for the audio, then on playback, the audio is way ahead of the video.
Maybe, a third or half a second ahead. I guess that's because the camera's taking too long to decode and send the video to the Windows camera app, but the audio's romping straight there through the awesome UAC-8.

So, some progress but not a workable solution.

Which means I'm back to trying to get the action cam itself to just work the way it should, with video and audio getting captured and sent down the USB cable to the computer where it's recorded in sync.

The action cam is an Akaso EK7000 which seems to be based on a generic iCatchTek SPCA6350 chip. The computer recognises it as such, that it's a USB audio device. Windows seems to have just installed some generic USB audio drivers cos I haven't gone and found any. Here are two messages related to the drivers/device. The earliest timestamp:
Device USB\VID_2AAD&PID_6353&MI_03\8&35f0aecd&0&0003 requires further installation.

Then one just after:
Driver Management concluded the process to install driver wdma_usb.inf_amd64_c4716625576eced6 for Device Instance ID USB\VID_2AAD&PID_6353&MI_03\8&35F0AECD&0&0003 with the following status: 0x0.

... which looks like success.

I'm puzzled that Windows seems to know what this thing is, has installed some drivers but then it won't let me alter the recording level in the normal way, by sliding the level control on the "levels" tab of the microphone properties page. That slider is stubbornly fixed (although not actually disabled) at zero.
Posts: 39
Joined: Fri Feb 10, 2017 2:17 pm