You are here

TC Electronic Nova System help please

For all things relating to guitars, basses, amps, pedals & accessories.

TC Electronic Nova System help please

Postby Neil 1877 » Sun Jan 12, 2020 9:42 pm

Hi I play my Nova through a Vox AC 30 VR
I can get the nova and vox levels in cinq properly and also the nova is changing the sound of my amp even when no effects are applied. Help ?
Neil 1877
Posts: 2
Joined: Sun Jan 12, 2020 9:30 pm

Re: TC Electronic Nova System help please

Postby Wonks » Mon Jan 13, 2020 8:49 am

Hi and welcome.

I have recently bought a a Nova system but I haven't done much with it yet. But have you followed the basic set-up procedures in the manual? I certainly had to adjust the master volume level to get a similar level through the Nova when clean to plugging straight into the amp. I would say that the manual is pretty poor, and not at all well laid out.

When you say that the Nova is changing the sound even when no effects are applied, in what way? is it adding distortion, or is the EQ different etc? Whilst there is no footswitch to turn it on and off, each overall program has an EQ block that is always on. If you bought your Nova used, then I expect someone will have set up the EQ to their taste, so I'd first have a look at the EQ settings and if the aren't flat, then set them flat and see if the with and without Nova sounds are now similar.
User avatar
Wonks
Jedi Poster
Posts: 10531
Joined: Thu May 29, 2003 12:00 am
Location: Reading, UK
Correcting mistakes on the internet since 1853

Re: TC Electronic Nova System help please

Postby brucie » Mon Jan 13, 2020 12:07 pm

Hi there Neil

Congratulations on your Nova, it is a great effects unit, but can be a bit tricky to set up. It is a juggling act of getting the input level and output levels matched up. Rule of thumb is if you have a high input gain (or are using additional drive pedals in front of the Nova) then you should set the output gain low. You access these under the Menu -> Levels options. I used to set my output to 8dBu, I found that worked well.

As mentioned above, check that the EQ hasn't been engaged and switched to something which is causing your tonal change.

If you need more help give me a shout, also I did a whole selection of YT videos on the Nova which might help you get up and running.

https://www.youtube.com/playlist?list=PL7fP0hVRilowxrqkAVKbnRSQGjLXxnVP0

Good luck!

All the best, Neil
brucie
Regular
Posts: 107
Joined: Wed Nov 13, 2002 1:00 am
Location: Manchester, UK
Neil S. Bruce - http://www.spencerbruce.com

Re: TC Electronic Nova System help please

Postby Neil 1877 » Mon Jan 13, 2020 1:58 pm

Thanks Wonks I will give that a go, your right it is second hand ! Neil
Neil 1877
Posts: 2
Joined: Sun Jan 12, 2020 9:30 pm


Who is online

Users browsing this forum: No registered users