You are here

Pedal not working after connecting to AC PSU.

For all things relating to guitars, basses, amps, pedals & accessories.

Re: Pedal not working after connecting to AC PSU.

Postby Arpangel » Mon Sep 21, 2020 11:35 am

Folderol wrote:Hmmm, less than 1k in costs - that's quite some profit margin :thumbdown:

But you forgot the gold plated case "designer" case, and the gold plated "designer case, oh yes, the gold plated "designer" case, hang on, I’m struggling too, to think of anything else that could justify that price tag, oh hang on again, how about certain names printed on the front panel?

:)
User avatar
Arpangel
Jedi Poster
Posts: 5873
Joined: Sat Jul 12, 2003 12:00 am

Re: Pedal not working after connecting to AC PSU.

Postby ef37a » Mon Sep 21, 2020 11:47 am

Arpangel wrote:
Folderol wrote:Hmmm, less than 1k in costs - that's quite some profit margin :thumbdown:

But you forgot the gold plated case "designer" case, and the gold plated "designer case, oh yes, the gold plated "designer" case, hang on, I’m struggling too, to think of anything else that could justify that price tag, oh hang on again, how about certain names printed on the front panel?

:)

You forgot the 99.99% pure Silver transformer wire which makes FA difference!

Dave.
ef37a
Jedi Poster
Posts: 12286
Joined: Mon May 29, 2006 12:00 am
Location: northampton uk

Re: Pedal not working after connecting to AC PSU.

Postby Arpangel » Mon Sep 21, 2020 2:47 pm

ef37a wrote:
Arpangel wrote:
Folderol wrote:Hmmm, less than 1k in costs - that's quite some profit margin :thumbdown:

But you forgot the gold plated case "designer" case, and the gold plated "designer case, oh yes, the gold plated "designer" case, hang on, I’m struggling too, to think of anything else that could justify that price tag, oh hang on again, how about certain names printed on the front panel?

:)

You forgot the 99.99% pure Silver transformer wire which makes FA difference!

Dave.

And what about the transformers encased in resin that has magical properties?
User avatar
Arpangel
Jedi Poster
Posts: 5873
Joined: Sat Jul 12, 2003 12:00 am

Re: Pedal not working after connecting to AC PSU.

Postby Folderol » Mon Sep 21, 2020 3:28 pm

In their defense I guess it is difficult these days to get the genuine wax impregnated caps - for that warm sound, unlike the harshness of those horrible plastic ones. I expect they go the whole nine yards and eschew standard electrolytic supply smoothing and use proper oil-filled types. They do look rather impressive with those ceramic studs on top. It's so reassuring being able to get to those high voltages easily.
...
...
I could go on :tongue:
User avatar
Folderol
Jedi Poster
Posts: 11716
Joined: Sat Nov 15, 2008 1:00 am
Location: The Mudway Towns, UK
Yes. I am that Linux nut.
Onwards and... err... sideways!

Re: Pedal not working after connecting to AC PSU.

Postby Arpangel » Wed Sep 23, 2020 7:24 am

Folderol wrote:In their defense I guess it is difficult these days to get the genuine wax impregnated caps - for that warm sound, unlike the harshness of those horrible plastic ones. I expect they go the whole nine yards and eschew standard electrolytic supply smoothing and use proper oil-filled types. They do look rather impressive with those ceramic studs on top. It's so reassuring being able to get to those high voltages easily.
...
...
I could go on :tongue:

I mentioned that I was given a box of valves recently, included were some wire wound Bakelite resistors, they look seriously cool, I don’t know what era they are from, I’ve just got them on a shelf in the studio, they look great.
User avatar
Arpangel
Jedi Poster
Posts: 5873
Joined: Sat Jul 12, 2003 12:00 am

Previous