You are here

HHB Circle 5 Actives - fuse keeps blowing

Page 1 of 1

HHB Circle 5 Actives - fuse keeps blowing

PostPosted: Fri Jul 31, 2020 10:33 am
by Pabs
Hi guys

I am having a problem with one of my HHB Circle 5 active monitors. In one of them, the fuse keeps blowing as soon as I power up. I'm using the correct 2A slow blow type as instructed by the manual. The other monitor of the pair works fine and doesn't have this problem

Any ideas what the problem might be?

Re: HHB Circle 5 Actives - fuse keeps blowing

PostPosted: Fri Jul 31, 2020 11:11 am
by James Perrett
Hi Pabs - good to see you back here. Unfortunately your problem could be caused by all kinds of things and it really needs to be looked at by someone knowledgeable. The first thing I would do is check the power supply and possibly try to separate the power supply from the amplifier in order to track down the fault. However, this isn't the sort of thing where you can just set out a procedure to follow as the steps that need to be taken depend on what you find.

Re: HHB Circle 5 Actives - fuse keeps blowing

PostPosted: Fri Jul 31, 2020 11:38 am
by Hugh Robjohns
A significant fault in the power supply, probably. If the fuse blows straight away it's something pretty catastrophic (in the electronic engineering sense). Probably repairable, though...

I'd suggest contacting HHB's service department.

Re: HHB Circle 5 Actives - fuse keeps blowing

PostPosted: Thu Aug 06, 2020 11:48 pm
by Pabs
Thanks guys. I'll have to contact them and see what they say

Cheers