You are here

Safari search issue

Report bugs & errors with the SOS forums, and web site. Please check existing discussions before posting.

Safari search issue

Postby desmond » Tue Sep 29, 2020 11:48 am

There's an ongoing search issue with Safari that's been bugging me a while, so I thought I'd better document it.

(We've had a similar issue before relating to caching here, iirc).

When you go to search, the first search you make will return no results. From that point on, search will work. Here's an example of me searching for "korg" - the first time I hit search I get no results, if I then search again, I get results.

This seems to be Safari (Mac) only - I don't think it happens in Chrome, for example, and also seems Ok on Safari iOS when I tried just now.

Image

Something to add to the list for the web team to look at, I guess...
User avatar
desmond
Jedi Poster
Posts: 10619
Joined: Tue Jan 10, 2006 1:00 am
mu:zines | music magazine archive | difficultAudio

Re: Safari search issue

Postby Luke W » Tue Sep 29, 2020 11:57 am

I've been getting the exact same issue in Firefox (on a Mac), but it's not happening every time.
User avatar
Luke W
Regular
Posts: 436
Joined: Thu Feb 19, 2009 1:00 am
Location: Northamptonshire, UK
Studio - Techical Audio Services - Bespoke Construction

Re: Safari search issue

Postby Dr Huge Longjohns » Tue Sep 29, 2020 12:12 pm

I find it quite frustrating that if you do a search in Google for a specific SOS item the results' links just take you to the SOS home page, not the topic that Google has found. So if I search SOS Korg the Google result will find me what I want, but click on it and you go back to the SOS home page not eg the Korg link that Google lists.
User avatar
Dr Huge Longjohns
Frequent Poster (Level2)
Posts: 3819
Joined: Thu Apr 10, 2003 12:00 am
Location: Gallifrey
"The performance is 99.9% of what people hear"- J. Leckie
"It's all complete nonsense, anyone who knows what they're doing can deliver great results with whatever comes to hand" - H. Robjohns

Re: Safari search issue

Postby blinddrew » Tue Sep 29, 2020 2:28 pm

Luke W wrote:I've been getting the exact same issue in Firefox (on a Mac), but it's not happening every time.
Actually I get the same thing in Chrome on a PC
User avatar
blinddrew
Jedi Poster
Posts: 12045
Joined: Sun Jul 05, 2015 12:00 am
Location: York
Ignore the post count, I have no idea what I'm doing...