You are here

CRT scope high voltage supply problem?

Customising, building or repairing your own gear? Need help with acoustic treatment or soundproofing? Ask away…

Re: CRT scope high voltage supply problem?

Postby Folderol » Wed Mar 05, 2014 7:56 pm

The ones in place for C78 & C79 are actually 1.6kV rated. As Dave says the circuit is very hard to read but they go from ground to the -1kV line.

Personally I very much doubt these two are faulty. Similarly I would be surprised if C76 or C77 were the problem. Remember these voltages are too high. If the caps had gone leaky I would expect them to be too low.
User avatar
Folderol
Jedi Poster
Posts: 11643
Joined: Sat Nov 15, 2008 1:00 am
Location: The Mudway Towns, UK
Yes. I am that Linux nut.
Onwards and... err... sideways!

Re: CRT scope high voltage supply problem?

Postby Adam Inglis » Thu Mar 06, 2014 7:12 am

Ah, thanks, I see now - I thought that was a crossing and not a connection at the top of those caps.
Ok, so it is probably a fault on the low voltage side of things.
I have measured the oscillation at 26kHz, when it should be 22 kHz, but I suppose that is just telling us what we already know.
User avatar
Adam Inglis
Regular
Posts: 427
Joined: Wed Sep 01, 2004 12:00 am
Location: Gold Coast Queensland Australia

Re: CRT scope high voltage supply problem?

Postby Folderol » Tue Jun 17, 2014 11:00 pm

Any developments on this?
User avatar
Folderol
Jedi Poster
Posts: 11643
Joined: Sat Nov 15, 2008 1:00 am
Location: The Mudway Towns, UK
Yes. I am that Linux nut.
Onwards and... err... sideways!

Re: CRT scope high voltage supply problem?

Postby Adam Inglis » Fri Jul 04, 2014 2:24 am

In a word... No!
I needed a scope to fix a few things around here, so I put that job aside, and bought one of these new-fangled digital scopes - a Rigol DS2070... which did the trick and the jobs got done, but now the NEW scope is on the fritz!
Unbelievable... :madas: (with steam coming out ears)
User avatar
Adam Inglis
Regular
Posts: 427
Joined: Wed Sep 01, 2004 12:00 am
Location: Gold Coast Queensland Australia

Re: CRT scope high voltage supply problem?

Postby Folderol » Sat Jul 05, 2014 5:16 pm

Hmm. You haven't done something to offend the god of oscilloscopes, have you? {Terry Pratchett ref.}
User avatar
Folderol
Jedi Poster
Posts: 11643
Joined: Sat Nov 15, 2008 1:00 am
Location: The Mudway Towns, UK
Yes. I am that Linux nut.
Onwards and... err... sideways!

Re: CRT scope high voltage supply problem?

Postby Adam Inglis » Mon Jan 14, 2019 11:27 am

So, still knocking down those NY resolutions, I've returned to this, 4 years later.

I replaced the 3 rectifiers on the HV side and lo and behold, my two beams have returned. I can move them vertically on the screen and focus them, however, they do not move across the screen with any timebase setting, so I'm assuming I need to look at my horizontal amplifier circuit.
Still, I'm getting somewhere...!
User avatar
Adam Inglis
Regular
Posts: 427
Joined: Wed Sep 01, 2004 12:00 am
Location: Gold Coast Queensland Australia

Re: CRT scope high voltage supply problem?

Postby Folderol » Mon Jan 14, 2019 5:22 pm

I'd quite forgotten about this one :shock:
Are you just getting two spots, or actual lines?
If it's lines, it's not the amplifier but the timebase - depending on the design it might still be the timebase if the amplifier is integrated in to it.
User avatar
Folderol
Jedi Poster
Posts: 11643
Joined: Sat Nov 15, 2008 1:00 am
Location: The Mudway Towns, UK
Yes. I am that Linux nut.
Onwards and... err... sideways!

Re: CRT scope high voltage supply problem?

Postby Adam Inglis » Tue Jan 15, 2019 12:05 am

Well they look like spots until you focus them sharply, then it appears they are very tight irregular shapes that don't don't change.

There is a horizontal amplifier section built into the mainframe, and there is a timebase "plug-in" that interacts with it. Both of these have a number of trims and different voltage points that I will need to check against the manuals calibration procedure.
User avatar
Adam Inglis
Regular
Posts: 427
Joined: Wed Sep 01, 2004 12:00 am
Location: Gold Coast Queensland Australia

Re: CRT scope high voltage supply problem?

Postby Adam Inglis » Wed Jan 16, 2019 8:08 am

Spots are now lines, after trimming the various DC voltages. And when the timebase decides to work, we get pretty waveforms!

I don't have an exact schematic for the timebase plug in, but I do have one for a similar unit. Looks like I have some research and measuring ahead of me.

My one concern re the EHT circuit:
the -1000 volt line is measuring around -1600 volts. The other voltages look OK, but I can't trim this one out. The beams do seem to be behaving as expected, responding to the vertical amps.
I wonder if in all my part replacements I've altered the frequency of the coil. Is this a worry if the CRT voltage sits that high (er... low)?
User avatar
Adam Inglis
Regular
Posts: 427
Joined: Wed Sep 01, 2004 12:00 am
Location: Gold Coast Queensland Australia

Re: CRT scope high voltage supply problem?

Postby Folderol » Wed Jan 16, 2019 8:22 am

Excessive EHT is not good, in that it can increase the energy at which the electrons hit the phosphor. It also tends to increase the scanning voltage required for a given deflection so might screw up the calibration.

Having said that, I don't know what the recommended range is for that CRT. What is the actual PDA voltage (+3kV one). That will be more important.
User avatar
Folderol
Jedi Poster
Posts: 11643
Joined: Sat Nov 15, 2008 1:00 am
Location: The Mudway Towns, UK
Yes. I am that Linux nut.
Onwards and... err... sideways!

Re: CRT scope high voltage supply problem?

Postby Adam Inglis » Wed Jan 16, 2019 10:42 am

When I turn it on, I get about 2800 volts on the PDA line, and about -1200 volts on the -1kV line. After some minutes these voltages climb to 4800 and -1700!

Reviewing the advice from this forum, I notice I never replaced C80 and it's associated diode D18 at the secondary winding that gives the extra 80 volts. I think they might be next.....
User avatar
Adam Inglis
Regular
Posts: 427
Joined: Wed Sep 01, 2004 12:00 am
Location: Gold Coast Queensland Australia

Re: CRT scope high voltage supply problem?

Postby Folderol » Wed Jan 16, 2019 12:06 pm

This is not good. Something is changing value as it warms up.

Things worth changing (if you haven't already).
C 72
C 73
R 122
Also check the DC supplies to the oscillator are stable - especially the +18V.
User avatar
Folderol
Jedi Poster
Posts: 11643
Joined: Sat Nov 15, 2008 1:00 am
Location: The Mudway Towns, UK
Yes. I am that Linux nut.
Onwards and... err... sideways!

Re: CRT scope high voltage supply problem?

Postby Adam Inglis » Wed Jan 16, 2019 12:09 pm

Page 3 ?
What a mission!
Schematic here
Description here but note there does seem to be some errors, e.g. I can't find D15 anywhere!

I was just going to add...
isn't it good practice to put a protection diode across the base and emitter of transistors that are involved with inductive circuits? Something about the EMF kick on switch-off?
User avatar
Adam Inglis
Regular
Posts: 427
Joined: Wed Sep 01, 2004 12:00 am
Location: Gold Coast Queensland Australia

Re: CRT scope high voltage supply problem?

Postby Adam Inglis » Wed Jan 16, 2019 12:12 pm

Folderol wrote:This is not good. Something is changing value as it warms up.

Things worth changing (if you haven't already).
C 72
C 73
R 122
Also check the DC supplies to the oscillator are stable - especially the +18V.

Thanks Will - I believe I've changed those caps early on, but I will check, and yes, I had better check all the low voltage DC levels again on the primary side.
User avatar
Adam Inglis
Regular
Posts: 427
Joined: Wed Sep 01, 2004 12:00 am
Location: Gold Coast Queensland Australia

Re: CRT scope high voltage supply problem?

Postby Wonks » Wed Jan 16, 2019 12:21 pm

The section referring to D15 does reference drawing 1065, whilst the drawing you've linked to is 681. Probably why you can't find it!
User avatar
Wonks
Jedi Poster
Posts: 10889
Joined: Thu May 29, 2003 12:00 am
Location: Reading, UK
Correcting mistakes on the internet since 1853

PreviousNext