You are here

Macbook Pro 15" (2015) "White Screen" Bother

For current or would-be users of Apple Mac computers, with answers to many FAQs.

Macbook Pro 15" (2015) "White Screen" Bother

Postby Freelance Subversive » Thu Jul 04, 2019 11:44 am

Has anybody experienced this or have insight into whether it's a hardware or software problem? This is the second time its happened in just over a week: the first was during my bi-annual 'OS maintenance' and the second today, during a not particularly system-taxing session. As you'll see in the images, it forms a vertical 'Bengal' stripe pattern.

Slight Distance
Image

Close-Up
Image

System: 2.5GHz, discreet AMD graphics; OS 10.11.6.

Thank you!

Edit: Forgot to mention…the session was still running when it happened, so was able to complete the take before hard resetting.
Freelance Subversive
Poster
Posts: 25
Joined: Wed Jul 18, 2018 5:21 pm

Re: Macbook Pro 15" (2015) "White Screen" Bother

Postby G-Doubleyou » Sat Jul 06, 2019 2:04 am

Have you tried to boot into safe mode, or from an external backup drive?
If you can then run the hardware test app.

Here is a procedure for troubleshooting.

https://blog.trendmicro.com/how-to-fix- ... te-screen/

Good luck
User avatar
G-Doubleyou
Frequent Poster
Posts: 949
Joined: Fri Feb 10, 2006 1:00 am
G-Dub Studio G-fx 2011 15inch 2.0GHz quad-core i7 Macbook Pro, LPX 10.3.2
2.3 GHz quad-core i7 Mini

Re: Macbook Pro 15" (2015) "White Screen" Bother

Postby Freelance Subversive » Thu Jul 11, 2019 12:33 am

Thank you for your reply.

I should have mentioned, I tried all the usual non-intrusive procedures the first time it happened, which had no effect and the hardware test didn't turn up anything, either. My previous experience with barn door-obvious component failure on another Macbook, suggests the test app has limited scope or is simply a bit random in what it detects.

I should also have clarified that it boots perfectly normally, however on two separate occasions the display turned white/'bengal striped' after the system had been running a while. The first (as mentioned in my earlier post), was during a clean up of the system drive (old apps, plugins etc.), i.e. not in anyway taxed; the second during a recording session. Both times the system continued to run quite happily it seems, enough that I was able to complete a take before having to hard-restart, in order to restore the display.

I can't really afford down time at the moment, so am very much trying to avoid re-installing the OS or having to take it in for inspection. Any further ideas would be most welcome.
Freelance Subversive
Poster
Posts: 25
Joined: Wed Jul 18, 2018 5:21 pm

Re: Macbook Pro 15" (2015) "White Screen" Bother

Postby desmond » Thu Jul 11, 2019 1:05 am

You're correct, the hardware test won't show up a defective GPU, it would likely only show if the GPU had failed completely.

Apple have their own specific proprietry tests at the Apple Store Genius Bars to stress a GPU and see whether any known issues are found - I've been through this procedure a few times...
User avatar
desmond
Jedi Poster
Posts: 8987
Joined: Tue Jan 10, 2006 1:00 am
mu:zines | music magazine archive | difficultAudio


Who is online

Users browsing this forum: No registered users