You are here

Create Aggregate Device?

Page 1 of 1

Create Aggregate Device?

PostPosted: Fri Apr 26, 2019 11:18 am
by james090
Its been a while since I did this, but can anyone tell me how to create an Aggregate Device on iMac with Built in output and Soundflower?

I use Ableton to record to Twisted Wave Audio editor live, and use Soundflower. All works fine except that with Ableton using Soundflower output and TW using Soundflower input, i cannot hear what i'm recording??

In TW I have selected "play through recording" but this only monitors and plays 'aloud' the recording when the record button is pressed/recording!

So i think I have to make an Aggregate device?

I have done this using both Soundflower and my Built in output but still no sound when used out on Ableton and in on TW?

I did use to use SoundFlower BED which took care of this but not sure its still compatible or being made for Hi-Sierra (me) and above?

Re: Create Aggregate Device?

PostPosted: Fri Apr 26, 2019 11:25 am
by james090
UPDATE : scrap everything I've said above, as I have now found the latest SoundFlowerBed hidden and buried away on a site.

This looks like SoundFlowerBed 2.0.0 which is from 2014? but not sure if theres a more updated recent version if anyone knows?

It seems to be working ok, but just wanted to check on any updates :)

Re: Create Aggregate Device?

PostPosted: Mon Jun 03, 2019 2:19 am
by braindead3xl
Look like this addresses the question of Mojave compatibility, even though the main extension hasn't been updated since 2014:

https://github.com/mattingalls/Soundflo ... /tag/2.0b2

I'm sure you've seen this too which also does the same thing:

https://rogueamoeba.com/loopback/