You are here

Focusrite Scarlett power up problem

Page 1 of 3

Focusrite Scarlett power up problem

PostPosted: Thu Nov 21, 2019 4:07 pm
by DanR
Hi
I use a Focusrite Scarlett 2i2 1st generation with Windows 10 and while it works fine, I can’t get the unit to power on when I turn on the laptop.
I have to unplug and plug it in again.
I’ve selected Focusrite as default audio in settings but when the PC is turned on again, the 2i2 is not recognised. No messages
or anything.
I have the latest drivers installed.
Any help appreciated.

Re: Focusrite Scarlett power up problem

PostPosted: Thu Nov 21, 2019 4:09 pm
by Wonks
Have you got the phantom power turned on? if so, try turning it off. Your laptop may not be able to supply sufficient current for the interface with the phantom circuit (at least on power-up).

Re: Focusrite Scarlett power up problem

PostPosted: Thu Nov 21, 2019 4:20 pm
by Hugh Robjohns
Or might it be that the Laptop switches off its USB ports when it sleeps and needs a prompt to fire them up again? Maybe a BIOS setting?

H

Re: Focusrite Scarlett power up problem

PostPosted: Thu Nov 21, 2019 5:15 pm
by DanR
Wonks wrote:Have you got the phantom power turned on? if so, try turning it off. Your laptop may not be able to supply sufficient current for the interface with the phantom circuit (at least on power-up).

Phantom power is off.
It’s strange because the red halos around the input gains flash when laptop is powered up but it goes no further.

Re: Focusrite Scarlett power up problem

PostPosted: Thu Nov 21, 2019 5:31 pm
by DanR
Hugh Robjohns wrote:Or might it be that the Laptop switches off its USB ports when it sleeps and needs a prompt to fire them up again? Maybe a BIOS setting?

H

Yes. Once the interface is on, the laptop switches it off when entering sleep mode.
It powers back up fine when prompted.
When the laptop is started from off, the Scarlett doesn’t start with it but other devices do.
It looks like the Focusrite drivers are not loading as Cubase can’t find the device when opened.
Disconnect then reconnect the USB cable and it powers up.

Re: Focusrite Scarlett power up problem

PostPosted: Thu Nov 21, 2019 7:33 pm
by John Egan
My Scarlett 18i6 (first generation) fires up perfectly when the system is switched on. I am using ASIO4ALL V2 drivers with the DAW and the latest drivers downloaded from the Focusrite site with other software. Have you spoken to Focusrite ? They were very helpful when I experienced a problem some months ago.
Regards, John

Re: Focusrite Scarlett power up problem

PostPosted: Thu Nov 21, 2019 7:40 pm
by Wonks
It does sound like it's more to do with the laptop than the Focusrite. Have you tried different power management settings, to see if a 100% full power mode works any differently?

Re: Focusrite Scarlett power up problem

PostPosted: Thu Nov 21, 2019 11:14 pm
by DanR
John Egan wrote:My Scarlett 18i6 (first generation) fires up perfectly when the system is switched on. I am using ASIO4ALL V2 drivers with the DAW and the latest drivers downloaded from the Focusrite site with other software. Have you spoken to Focusrite ? They were very helpful when I experienced a problem some months ago.
Regards, John

Thanks.
I’ve heard of ASIO4ALL but thought no need for it if the device’s current drivers are available.
I’ll contact Focusrite anyway.

Re: Focusrite Scarlett power up problem

PostPosted: Thu Nov 21, 2019 11:29 pm
by blinddrew
Just another +1 contacting focusrite, they've been really helpful to me on a few occasions.

Re: Focusrite Scarlett power up problem

PostPosted: Fri Nov 22, 2019 11:05 am
by Pete Kaine
Just wondering if it shows up at all in device manger when first turned on?

Sometimes drivers can block each other when grabbing resources and the unplug/replug process forces it to reload afresh.

Next time you start and the interface doesn't, jump into control panel/devicemanger and check for the Focusrite having an exclamation mark next to it.

What I'm wondering is, if multiple installations of the driver itself (ghosting) is otherwise stealing resouces from itself.

https://www.nirsoft.net/utils/usb_devices_view.html

Grab that and run it. Before doing so, unplug anything USB wise that isn't the keyboard/mouse/essential to letting you run the above program.

I would rattle through and remove any multiple ghost entries and anything that is obviously no longer required. It might have no effect, but couldn't hurt to give it a go.

Re: Focusrite Scarlett power up problem

PostPosted: Fri Nov 22, 2019 12:06 pm
by CS70
Sounds like a USB power-up handling issue in the laptop to me, not maybe a bug per se but something with the combination of what the laptop does and the interface expects during powerup. It used to be quite a common issue with USB devices.

Nowadays is most often a power management issue - do you have the "allow the OS to manage this device" turned off in the "Power" tab of all your USB root devices?

Basically you want your USB ports to be always on.

Re: Focusrite Scarlett power up problem

PostPosted: Fri Nov 22, 2019 5:48 pm
by DanR
CS70 wrote:
Nowadays is most often a power management issue - do you have the "allow the OS to manage this device" turned off in the "Power" tab of all your USB root devices?

Basically you want your USB ports to be always on.

Thanks. Not sure whether to look in Device Manager or Power Management for that option.
Had a look at Universal Serial Bus Controller in Device Manager and only the USB 3.0
one has Power Management option.
The box ‘Allow the computer to turn off this device to save power’ is checked.
I think I have the Scarlett running off a USB 2.0 socket though.

Unable to find any settings with the exact wording you gave.

Re: Focusrite Scarlett power up problem

PostPosted: Fri Nov 22, 2019 5:56 pm
by DanR
Pete Kaine wrote:
Next time you start and the interface doesn't, jump into control panel/devicemanger and check for the Focusrite having an exclamation mark next to it.

The Focusrite entry looks fine and there’s no exclamation mark.
Says device is working properly although it’s plugged in and not on.

Re: Focusrite Scarlett power up problem

PostPosted: Fri Nov 22, 2019 6:10 pm
by CS70
DanR wrote:The box ‘Allow the computer to turn off this device to save power’ is checked.
I think I have the Scarlett running off a USB 2.0 socket though.

Unable to find any settings with the exact wording you gave.

That's the one. You want to uncheck it.

My apologies, mine wasn't exact wording at all - just a figment from memory. :-)

Just to make sure, go thru all the devices in Device Manager and uncheck it for all of them (maybe what you just wrote is that you already did, but not sure).

Re: Focusrite Scarlett power up problem

PostPosted: Sat Nov 23, 2019 12:18 pm
by DanR
CS70 wrote:
DanR wrote:The box ‘Allow the computer to turn off this device to save power’ is checked.
I think I have the Scarlett running off a USB 2.0 socket though.

Unable to find any settings with the exact wording you gave.

That's the one. You want to uncheck it.

My apologies, mine wasn't exact wording at all - just a figment from memory. :-)

Just to make sure, go thru all the devices in Device Manager and uncheck it for all of them (maybe what you just wrote is that you already did, but not sure).

I unchecked it and plugged the interface into the USB 3.0 socket and the lights didn't even flicker like before.
There’s no other devices other than this that have a Power Management option.